+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Navigation widget changed dramatically in 6.3

Navigation widget changed dramatically in 6.3

3 posts, 0 answered
  1. Luke
    Luke avatar
    56 posts
    Registered:
    18 Mar 2013
    04 Apr 2014
    Link to this post

    I found this out the hard way, after we'd upgraded to 6.3.

     When you've dragged a navigation widget into the page & attempt to edit it, the resulting UI is completely different and doesn't allow you to select any template (tree vs. list, etc.)

     Why the change, and why no warning for the change? I don't understand why a software vendor that markets itself around "customer experience" makes that a low priority. New features should be balanced with continuity and customer expectations. The release notes and breaking changes make no mention of this issue.

     Oh, and also - how do I edit the navigation menu now? The controls I am accustomed to have vanished.

  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    04 Apr 2014 in reply to Luke
    Link to this post

    Well actually it didn,t change if you had it on the page previously...the old nav was the bloaty radcontrols version.  What you see there is the new clean markup version with which you can actually tweak the markup.

    So the upgrade to 6.3 didn't delete that widget from your page and replace it with the new widget...sorry, but just didn't happen.  Maybe you dleted it and readded the 'new' one, or someone else did.

     Nothing happened to the old widget, it's still there for legecy puroposes, however it's depreciated.  There was PLENTY of warning well before 6.3 on the roadmap and IN the release notes.

     What is borked though is that the upgrade never installed the widget templates for your dropdown.  I've seen this happen on about 3 sites.  Support can help you restore them...I used JustDecompile and copypasted the markup into a new template. 

  3. Luke
    Luke avatar
    56 posts
    Registered:
    18 Mar 2013
    04 Apr 2014 in reply to Steve
    Link to this post

    I didn't have it on the page previously. When I'm creating new pages, the legacy widget doesn't appear in my editor toolbox. I can see that this is likely a config thing on our side and probably not really worth getting into.

    Long story short, A.) the newer Sitefinity version has changed the way users work with navigation menus, B.) the new way is apparently better from a tweak-ability of markup standpoint. I'm not a developer - I'm a user, so I'll take your word for and easily concede that point, but I maintain that it is way too much to ask to have to play "Where's Waldo" to find out important workflow changes between versions. It's not as if Telerik has no way to put important notices in front of users. The Sitefinity dashboard represents a huge chunk of underutilized real estate in this respect.

3 posts, 0 answered