+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / New Project errors: headerWidgetElement is undefined

New Project errors: headerWidgetElement is undefined

6 posts, 0 answered
  1. Rory
    Rory avatar
    44 posts
    Registered:
    22 Mar 2012
    19 Apr 2013
    Link to this post
    Hello.  we are using a siteifnity 5.3 project and are getting errors when deleting Image and document libraries.

    The error in Firefox is " TypeError: headerWidgetElement is undefined "
    The error in Chrome is " Uncaught TypeError: Cannot call method 'find' of undefined "
    The error in IE9 is " error Line: 4620 Error: Unable to get value of the property 'find': object is null or undefined "

    This is happening with our dev project as well as new empty projects i create to test this issue.   It happens when i create a new image library, add an image to it and go back to the library listing.  Then refresh the page again and then delete that library and the error will appear after the page refreshes.  All being done through the UI.

    How can i get rid of these errors?  This causes a popup in IE9 so it is not something that can be ignored.  The error is coming from Telerik.Web.UI.Common.Core.js.

    Any help is appreciated.  Thanks
  2. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    06 Dec 2016
    24 Apr 2013
    Link to this post
    Hi Rory,

    Can you please let us know if the deleted library is by chance the Default Image/Video/Document library.

    We have tried reproducing the problem on a local Sitefinity 5.3 project, but have not been able to replicate it locally. Can you please take a look at this sample video we've recorded and let us know if we're not missing an important part in reproducing the issue?

    Sitefinity versions previous to 5.4 had a bug related to deleting the default library for media content, resulting in similar behavior to the one described. In the second part of the above linked video I've demonstrated this behavior. If that's the case, the bug has been fixed for our Sitefinity 5.4 release, and upgrading to that version should bring the designed functionality.

    Kind regards,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Rory
    Rory avatar
    44 posts
    Registered:
    22 Mar 2012
    29 Apr 2013 in reply to Boyan Barnev
    Link to this post
    Hi Boyan.  thanks for the reply.  It is not the default libraries that i am deleting, they are new libraries that do this.  your video is a little different.  i will provide more detail:

    when i delete a library from the same link as you did in the video: ~/Sitefinity/Content/Images/Albums, i too get no error.  

    To reproduce the error:
    - after creating the new library you'll probably be on the Sitefinity/Content/Images/Albums page.
    - click the 'back to images' link.
    - then on the right hand side menu where it says 'Images by Library', click on the new library.
    - you should now be at the ~/Sitefinity/Content/Images page for that library which displays the images in that library.
    - now click the 'Library Actions' drop down menu and select delete and confirm the delete.
    - you should now get the error.
  4. Strahil Strahilov
    Strahil Strahilov avatar
    24 posts
    Registered:
    06 Nov 2014
    01 May 2013
    Link to this post
    Hi Rory,

    I reproduced the error following your scenario. This bug was fixed in Sitefinity 5.4. Our recommendation is to upgrade your project to 5.4 or higher.

    Kind regards,
    Strahil Strahilov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Rory
    Rory avatar
    44 posts
    Registered:
    22 Mar 2012
    01 May 2013 in reply to Strahil Strahilov
    Link to this post
    Hi Strahil, thanks for the reply. 

    i dont think we want to go through upgrading right now since we don't know what that will do to the code that took us over a year to get working.   Just another issue we will have to ignore for now i guess.  thanks.
  6. Strahil Strahilov
    Strahil Strahilov avatar
    24 posts
    Registered:
    06 Nov 2014
    03 May 2013
    Link to this post
    Hi Rory,

    I understand your concerns. However my suggestion is to upgrade to Sitefinity 5.4 version. This release was mainly for bug fixing with a few breaking changes, that might not affect your custom implementations.
    You can check the breaking changes notes for 5.4 version here.
    You can also go through the release notes for Sitefinity 5.4. here.

    Before going to through the upgrade, make sure you backed up all you files and Database. For more detailed information about the upgrade click here.

    Regards,
    Strahil Strahilov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
6 posts, 0 answered