1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / RadEditor tools not showing after upgrade to .net 4.0

RadEditor tools not showing after upgrade to .net 4.0

6 posts, 0 answered
  1. Samson
    Samson avatar
    4 posts
    Registered:
    23 Apr 2011
    30 Aug 2011
    Link to this post
    Hello,

    After updating my site to .net 4.0 the radeditor no longer shows the icons for the tools. I'm not receiving any type of error messages. Here is my set up I'm using a custom skin for the control by the way:

    <telerik:RadEditor ID="DescriptionEditor" runat="server"
                    DialogHandlerUrl="~/Telerik.Web.UI.DialogHandler.axd"
                    Width="100%"
                    ToolsFile="~/ToolsFileLimited.xml"
                    ImagesFilters="*.gif,*.png, *.jpg,*.jpeg"
                    EditModes="Design"
                    EnableEmbeddedSkins="false" Height="250px"
                    >
                    <Content>
    </Content>
                    <SpellCheckSettings DictionaryPath="~/RadControls/Spell/TDF/" />       
                </telerik:RadEditor>

  2. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    02 Sep 2011
    Link to this post
    Hi Samson,

    Can you please share with us some additional information on the toolsfile you are using and the exact use case scenario where you have implemented the RadEditor, as the issue does not reproduce on our side. Please take a look at the below code sample and the attached screenshot showing its representation on one of my project's pages where I have the control added.
    <asp:Panel runat="server" ID="EditorPanel">
    <telerik:RadEditor
                        ID="DescriptionEditor"
                        runat="server"                   
                        Width="100%"                   
                        EditModes="Design"
                        DialogHandlerUrl="~/Telerik.Web.UI.DialogHandler.axd"
                        ToolsFile="~/ControlTemplates/StandardToolsFileCustom.xml"
                        Content="" >                 
                    </telerik:RadEditor>
    </asp:Panel>


    Best wishes,
    Boyan Barnev
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  3. Samson
    Samson avatar
    4 posts
    Registered:
    23 Apr 2011
    02 Sep 2011
    Link to this post
    Thanks for your response, I forgot in addition to the upgrade we moved around some of our project folders so it was most likely a path issue which would explain why you couldn't reproduce it. I can't seem to find the file where the path to the css is placed the person who set this site up is no longer with the company so we just decided to set it to the default telerik skin.

    Also this had more to do with the skin not showing up than the tools, everything worked but I just don't have the image for the icons
    I also followed the steps on this page to make it the custom skins Creating a Custom Skin for RadEditor for ASP.NET AJAX from an Existing One
  4. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    03 Sep 2011
    Link to this post
    Hello Samson,

    I apologize if I didn't get you correctly, but can you please clarify what the current problem is - do you still have no icons for the tools in the editor toolbar, or it's the skin that's not applying. Also, can you please share with us some more information on the exact implementation you have for the RadEditor - are you trying to customize Sitefinity's built in content editor or you're using it inside a user control/custom module?

    All the best,
    Boyan Barnev
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  5. Samson
    Samson avatar
    4 posts
    Registered:
    23 Apr 2011
    04 Sep 2011
    Link to this post
    I'm having issues applying the skin last post I attached an image.  I'm using it inside a custom control/module don't know if this helps or not but this is also a dnn website project
  6. Samson
    Samson avatar
    4 posts
    Registered:
    23 Apr 2011
    06 Sep 2011
    Link to this post
    Ok let me start over, the custom skin for the radEditor is not showing, I followed the direction on this page: Creating Custom Telerik skins for radeditor, but nothing shows up I even tried looking at the page soucre to see if the Editor.mySkin.css file was being linked but I didn't see it. This is inside of a module in my DNN website. if someone could change to the title to read RadEditor Skin not showing after upgrade to .net 4.0 that would be appreciated

    note: this did work before the upgrade
6 posts, 0 answered