+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / RadRadialGauge issue in Sitefinity 7.3

RadRadialGauge issue in Sitefinity 7.3

6 posts, 0 answered
  1. Jason
    Jason avatar
    5 posts
    Registered:
    05 Feb 2014
    27 Jan 2015
    Link to this post

    We have a Sitefinity widget that uses the RadRadialGauge. We're using Sitefinity 7.3.5610.0

    Here's why I experience:

    1. Static ASPX Page - To test I created a static test.aspx page and published this to my DEV server. The RadRadialGauge appears and works as expected, no issues. This page references the same widget as in 2.
    2. Sitefinity Page (Published page) - RadRadialGauge does not appear, but rest of widget does. For some reason only the RadRadialGauge is missing.

    I checked logs, etc and no errors are show.

    The code is pretty simple:

    <telerik:RadRadialGauge runat="server" ID="gaugePoints" Width="300px" Height="300px">
        <Scale Min="0" Max="100" MajorUnit="30">
            <Labels Format="{0} points" />
            <Ranges>
                <telerik:GaugeRange Color="#ff7a00" From="0" To="30" />
                <telerik:GaugeRange Color="#ffc700" From="30" To="60" />
                <telerik:GaugeRange Color="#8dcb2a" From="60" To="100" />
            </Ranges>
        </Scale>
    </telerik:RadRadialGauge>

  2. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    30 Jan 2015
    Link to this post
    Hi,

    Would it be possible to let me know if the widget appears wen you access the page as anonymous user? If you have inline editing enabled, there could a conflict with RequireJs that produces an error preventing the gauge from appearing.

    Regards,
    Atanas Valchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Jason
    Jason avatar
    5 posts
    Registered:
    05 Feb 2014
    30 Jan 2015 in reply to Atanas Valchev
    Link to this post

    Thanks Atanas.

    We're using LDAP for validation and other part of our master pages require the user to be logged in.

    Inline editing is enabled and the widget (ascx) using AJAX. Is there a way to isolate this?

    I'm setup as an Administrator. Is there a way to globally disable in-line editing?

    J

  4. Jason
    Jason avatar
    5 posts
    Registered:
    05 Feb 2014
    30 Jan 2015 in reply to Jason
    Link to this post

    Sorry...disabled in-line editing and the widget works!
    Adminstration--> Settings --> Advanced --> Pages

    We plan to use in-line editing. Any chance this can coexist with our custom widgets.

     J

  5. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    31 Jan 2015 in reply to Jason
    Link to this post

    What if you remove the radradialguage and replace it with the kendoui version?

     Anyway, use firefox and firebug and in the console tab, you have javascript errors yes?...what does it say?

  6. Jason
    Jason avatar
    5 posts
    Registered:
    05 Feb 2014
    26 Feb 2015 in reply to Steve
    Link to this post

    I get 4 errors with ScriptResource.axd when we have Inline Editing enabled. None when it's turned off. They are: 

    1. Uncaught TypeError: undefined is not a function

    2. Uncaught Error: Mismatched anonymous define() module: function (){(function(a,aI){var V=window.kendo=window.kendo||{cultures:{}},C=a.extend,t=a.each,P=a.isArray,ar=a

    3.  Uncaught Error: Mismatched anonymous define() module: function (){(function(a,bf){var S=document,ar=window.kendo,H=ar.dataviz={},w=ar.Class,a7=ar.template,aA=a.map,aI=a.noop,an=a.inArray,be=a.trim,aB=Math,K=ar.deepExtend;
    var aU=function(X){return a7(X,{useWithBlock:false,paramName:"d"});

    4. Uncaught Error: Mismatched anonymous define() module: function (){(function(a){var

    How do I get Telerik and Sitefinity to place nicely? :-)

    J

6 posts, 0 answered