1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Search problem

Search problem

4 posts, 0 answered
  1. sathiyaseelan
    sathiyaseelan avatar
    82 posts
    Registered:
    26 Aug 2008
    20 Apr 2011
    Link to this post
    Hi,

    I am using default search control using sitefinity 4 in my site. After creating the search index first time it searched the results. but after re-indexing, the folder inside /App_Data/Sitefinity/Search got removed and getting an message "Exception of type 'System.Web.HttpUnhandledException' was thrown." and if I delete, re-create search with another name then on same re-indexing am getting "You are trying to access item that no longer exists. The most probable reason is that it has been deleted by another user." Also I didn't see any folder created with the same index name.

    Please tell me on urgent basis. This was not there on version 3.7... its quite strange.

    Thanks
  2. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    21 Apr 2011
    Link to this post
    Hi sathiyaseelan,

    Can you tell me if you have any custom controls on a page that is getting indexed? You can have custom controls on your pages, however if any of the controls contain code which somehow messes up with search engine indexation you may experience errors like this one. Have you tried to create a new website from the Project Manager and add some of the default controls and then index it? Can you run such a test and check if the error still shows up. If the problem comes from a custom control you need to escape the crawler request. Please refer to the following code sample:

    if (this.Page.Items["IsInIndexMode"] == null)
     {
      // your logic here.
     }

    Don't forget that If you want to get data from pages, make sure that Static HTML checkbox is checked.

    Best wishes,
    Victor Velev
    the Telerik team

  3. sathiyaseelan
    sathiyaseelan avatar
    82 posts
    Registered:
    26 Aug 2008
    21 Apr 2011
    Link to this post
    Hi,

    Thanks for your reply.

    I wrapped the custom navigation code with the code you mentioned. Still I am having the problem.

    Why is such problem happening in sitefinity 4..It was not there in sitefinity 3.7.?
    What is the solution you have to fix it now?
    Can you tell me at least how to implement custom search control for this.?

    Thanks
    sathya



  4. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    21 Apr 2011
    Link to this post
    Hello sathiyaseelan,

    I can suggest you few workarounds but first can you tell me:

     - which version of Sitefinity do you use for your project ?
     - do you have a custom master page which you have applied to your website?

    Last but not least in importance, can you check the following forum article which contains valuable information regarding your case.

    You can also find the following code useful:

    protected void Page_Load(object sender, EventArgs e)
    {
        if (this.GetIndexRenderMode() != Telerik.Sitefinity.Web.UI.IndexRenderModes.Normal)
            return;
    }


    All the best,
    Victor Velev
    the Telerik team

4 posts, 0 answered