+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Sitemap Generation Tool required modules

Sitemap Generation Tool required modules

3 posts, 1 answered
  1. Dawid
    Dawid avatar
    15 posts
    Registered:
    30 Jan 2012
    08 Oct 2014
    Link to this post

    The sitemap generation throws a number or exceptions regarding missing "config" sections when modules are disabled.

     For instance, if you don't need forums, blogs or events and those modules are disabled, you get the following type of exception in the logs (and the sitemap generation fails) :

    Type : System.Exception, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089<br>Message : The configuration 'EventsConfig' is not registered<br>Source : Telerik.Sitefinity<br>Help link : <br>Data : System.Collections.ListDictionaryInternal<br>TargetSite : Void VerifySectionRegistered(System.Type, System.String)<br>HResult : -2146233088<br>Stack Trace :    at Telerik.Sitefinity.Configuration.Config.VerifySectionRegistered(Type sectionType, String sectionName)<br>   at Telerik.Sitefinity.Configuration.Config.GetSectionInternal(Type sectionType, Boolean safeMode, String sectionName)<br>   at Telerik.Sitefinity.Configuration.Config.GetSectionPrivate[TSection](Boolean safeMode)<br>   at Telerik.Sitefinity.Modules.Events.EventsManager.get_ProvidersSettings()<br>   at Telerik.Sitefinity.Data.ManagerBase`1.GetProvidersSettings()<br>   at Telerik.Sitefinity.Data.ManagerBase`1.Initialize()

    I'm assuming this can be configured via Settings/Pages/Sitemap filters?

  2. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    06 Dec 2016
    09 Oct 2014
    Link to this post
    Hi,

    This is a known issue that Sitemap throws errors in some cases when content modules are disabled in Sitefinity 7.1. Would it be possible for your to inform us what is the version that you are using? In the ticket you have specified Sitefinity 7.2.5310.

    I would like to inform you that the problem has been fixed in one of the internal builds for Sitefinity 7.1. (release notes).

    In order to resolve the issue at your end you have two possibilities:
    - Activate that modules
    - Upgrade your project to one of the internal builds of Sitefinity 7.1 or to Sitefinity 7.2.

    Upgrade instructions could be found in our documentation on the following article:

    http://www.sitefinity.com/documentation/documentationarticles/installation-and-administration-guide/upgrade

    Internal builds are available in your account under Products & Subscriptions -> Latest internal builds. Select a product and version and you will be able to review the available internal builds.

    Regards,
    Stefani Tacheva
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
    Answered
  3. Dawid
    Dawid avatar
    15 posts
    Registered:
    30 Jan 2012
    09 Oct 2014 in reply to Stefani Tacheva
    Link to this post

    Hi Stefani,

    Thanks for the info, might help other people.

    In our case, we're running on Azure Websites, so to have the sitemap in the root folder, I created my own sitemap generator, making the issue go away.

    Cheers.

3 posts, 1 answered