1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Stylebuilder Theme Doesn't Apply

Stylebuilder Theme Doesn't Apply

7 posts, 0 answered
  1. Jaime Weise
    Jaime Weise avatar
    120 posts
    Registered:
    02 Nov 2008
    13 May 2011
    Link to this post
    Step One Create Theme at stylebuidler.telerik.com (use firefox)
    After, creating a theme at stylebuidler.telerik.com, I unzipped it and added to the Global directory, followed by registering it in the settings/advanced/appearance/frontend settings under the name of my theme. All the css that was suppose to be pulled from my newly registered theme was added to the theme. I applied the theme to a template and it worked as expected, so far. 

    Add the Menu to the Template Page
    The next step, I added the navigation control to the page and set the Skin and the SkinID to my theme name. I tested the page but the navigation is not taking on the custom menu theme. I checked the html and the classes rendered are "RadMenu RadMenu_Sitefinity". I can't seem to configure it to change the classes to RadMenu RadMenu_MyCustomTheme. There must be something simple I am missing.

    I have had success in the past. 
    By the way, I am working on SF 4.1 
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    13 May 2011
    Link to this post
    Hello jwize,

    There could be problem if you use skin files. We have bug with the skin file and we suggest that you should move the css classes in the theme styleshet. Also make sure that the theme is properly registered

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    13 May 2011
    Link to this post
    Dear Ivan

    I use custom skin on a tab. Is the described bug related to RadMenu only. Because if it is not then we might be able to help jwize anyhow.

    @jwize

    I have a skin created for a tabstrip (which is working)
    I have my own master.master page and added a link to my css files (I have them in ~/css/)

    When you use firebug in firefox and check the styles do you see your own styles and are these overruled by SF or dont you see your css styles at all?

    It would be good if you could attach a screen shot of the firebug css styles so one can see a bit more what is going on. Maybe even a screencast of your settings as well as debuging in FF. www.jing.com is free.

    This will help in helping you.

    Regards Markus
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    13 May 2011
    Link to this post
    Hello Markus ,

    The issue is related to the skin file. The problem is not related to specific controls.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    13 May 2011
    Link to this post
    Dear Ivan

    If I understand you correct stylebuilder generates a RadMenu custom skin that does not work?

    Because as I said I use a custom skin on a SF Navigation TabStrip and it works.

    Markus
  6. Jaime Weise
    Jaime Weise avatar
    120 posts
    Registered:
    02 Nov 2008
    13 May 2011
    Link to this post
    What Skin File are you talking about?
    I am not using a Skin file unless there is a default skin file I am not aware of.  So, even still I am left without the answer. It is clear that the css in the RadMenu should render the Theme Name. There isn't anything special that is happening. It is about what is not happening. How do I get the RadMenu to render the class names correctly. 

    So far I have gone into the Navigation Control--as you call it-- and set the SkinID and Skin to the name of my theme. I have tried variations one or the other or both with no avail. 

    Jaime
  7. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    16 May 2011
    Link to this post
    Dear Jaime

    I might be off totaly but this is how I do it.

    When I create a skin with Stylebuilder and download it I get a folder and a css file.

    For exmplae PanelBar and PanelBar.MySkin.css (MySkin is the name of the skin I created in Sylebuilder.

    --------------------

    I usually have a ~/css folder on my root site and include links to the  PanelBar.MySkin.css in my masterpage.

    Then I drag the panel bar in the backend to the page set the skin to MySkin (again the part in PanelBar.MySkin.css where MySkin is the name you gave your skin in stylebuilder when you build your skin)

    And make sure to set EnableEmbededSkins to false.

    -----------------

    I assume that this would also work if you put your skin files in your theme folder.

    Unless your theme and your Skin are named the same you need to set the skin to the name PanelBar.MySkin.css (MySkin) and not to the theme name.

    Hope this helps

    Markus
7 posts, 0 answered