+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Transferring Site To New Server Problems (Images Not Showing)

Transferring Site To New Server Problems (Images Not Showing)

4 posts, 0 answered
  1. Grant
    Grant avatar
    1 posts
    Registered:
    31 Jan 2011
    31 Jan 2011
    Link to this post
    I am transferring a Sitefinity 3.7 Site from the server it's on, over to another server (from IIS 6 to IIS 7) and seem to be having some problems. The content managed images within the site all seem to be showing 404 errors. I have copied the database to the new server, and copied all the files to the new server changing the connection string to suit. All of the site works besides the images. Does anyone have a solution or anysuggestions?

    Thanks in advance.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    31 Jan 2011
    Link to this post
    Hi Grant,

    Please check whether you have HandlerMappings for *.sflb.ashx and *.tmb.ashx registered in IIS. Compare the HandlerMappings between your IIS servers. There could be difference in the mappings you use.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Dennis
    Dennis avatar
    2 posts
    Registered:
    04 Feb 2009
    16 Nov 2012
    Link to this post
    Ivan --

    I am having a similar issue when deploying a Sitefinity 5.x issue to IIS 6.  The handler mappings that you list are not there on the site; however, I do not have a working site for comparison.

    Would you care to enlighten us on what files those mappings should map to?

    Thanks,
    Dennis
  4. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    20 Nov 2012
    Link to this post
    Hi Dennis,

    The problems you are encountering with Sitefinity 5 and IIS6 are actually known issues, which you can fix by adding entries for the different static files in your httpHandlers section of the webconfig. For example if you want to have the .png files served, you will have to add:

    <add verb="*" path="*.png" type="System.Web.StaticFileHandler" />

    You can also add entries for .css, .jpg, .swf and other static files.

    Greetings,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered