1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Turning off compression

Turning off compression

2 posts, 0 answered
  1. Martin Kulov
    Martin Kulov avatar
    9 posts
    Registered:
    30 Jan 2008
    24 Mar 2012
    Link to this post
    Hi,

    I have a SF 5.0.2523.0 sample site. I tried turning off compression by setting the following element in web.config:
    <urlCompression doDynamicCompression="false" doStaticCompression="false" dynamicCompressionBeforeCache="false" />

    However I can still see in Fiddler that my output gets gzip compressed.
    Is there any other switch I need to turn off?

    Thanks!
  2. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    26 Mar 2012
    Link to this post
    Hey Martin,

    Are you sure you saw it right? At the top right inspector window Fiddler will show that it's capable of serving 'gzip, deflate' but when I check the content I'm seeing the following:

    HTTP/1.1 200 OK
    Cache-Control: no-cache
    Pragma: no-cache
    Content-Type: text/html; charset=utf-8
    Expires: -1
    Server: Microsoft-IIS/7.5
    X-AspNet-Version: 4.0.30319
    X-Powered-By: ASP.NET
    Date: Mon, 26 Mar 2012 09:58:16 GMT
    Content-Length: 7898
     
    HTTP/1.1 200 OK
    Cache-Control: no-cache
    Pragma: no-cache
    Content-Type: text/html; charset=utf-8
    Content-Encoding: gzip
    Expires: -1
    Vary: Accept-Encoding
    Server: Microsoft-IIS/7.5
    X-AspNet-Version: 4.0.30319
    X-Powered-By: ASP.NET
    Date: Mon, 26 Mar 2012 09:59:08 GMT
    Content-Length: 3010

    By just changing those 3 options in the web.config...

    Jochem
2 posts, 0 answered