+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Twitter Feed not working

Twitter Feed not working

3 posts, 0 answered
  1. Chris
    Chris avatar
    8 posts
    Registered:
    09 Feb 2009
    11 Mar 2015
    Link to this post

    I've tried setting up a Twitter feed using the "Twitter Feed" widget. 

    I setup a new Twitter app using the Sitefinity Twitter app credentials and associated it with my Twitter account.

    I then added the "Twitter Feed" widget to the page and chose the credentials I had just created.

    It doesn't output anything on the page?

    It makes a call every few seconds to http://localhost/Services/Content/PublishingDataService.svc/c4681eba-4fa8-6562-a286-ff0000dc48fe/?take=20 but nothing actually appears on the page?

    I can see on the page a jsTemplate var template = "<li class='sfTweetItem'><img src='#UserAvatar' alt='avatar' class='sfTweetAvatar'/><div class='sfTweetWrp'><b class='sfTweetAuthor'>#Username</b><i class='sfTweetDate'>#LastModified</i><p class='sfTweetContent'>#Content</p><a href='#Link' class='sfExpand'>Expand</a></div></li>";

    This looks like it should be populated with the returned content but nothing ever appears?

  2. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    29 Nov 2016
    16 Mar 2015
    Link to this post
    Hello Chris,

    Along with the Tweeter feed widget settings, would you please check and confirm you have Twitter feed created as per that article and it is Run.

    I hope this helps.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Chris
    Chris avatar
    8 posts
    Registered:
    09 Feb 2009
    16 Mar 2015 in reply to Svetoslav Manchev
    Link to this post
    Thanks, the external feed had not been run. I didn't realise this was part of the steps so thanks for clarifying
3 posts, 0 answered