+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Users not loading when using IIS

Users not loading when using IIS

4 posts, 1 answered
  1. Mark
    Mark avatar
    20 posts
    Registered:
    15 Oct 2012
    26 Feb 2013
    Link to this post

    Sitefinity 5.4, Windows Server 2012, MS SQL Server 2012, IIS 8.0

    I am unable to pull up the backend Users page with a brand new site, using IIS 8.0 (app pool as network service).  That page continually spins the loading message.

    The Pages backend page returns several error one of which is a 404.

    What configuration needs done on IIS 8.0 to get the site to respond?

     

  2. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    01 Mar 2013
    Link to this post
    Hi Mark,

    I believe the problem is a compatibility issue since you are running Windows Server 2012. The platform is not supported by Sitefinity and thus the unpredictable behavior. Please take a look at our System Requirements page.

    All the best,
    Pavel Benov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  3. John
    John avatar
    3 posts
    Registered:
    08 May 2012
    17 Apr 2013 in reply to Pavel Benov
    Link to this post
    Hi Pavel,

    According to the requirements page, Windows Server 2012 is supported

    Server-side requirementsMicrosoft® Windows Server 2003, 2008, 2008 R2, 2012, Windows Vista, Windows 7, Windows 8, Windows Azure32-bit or 64-bit operating systemInternet Information Services 6.0 to 8.0

    I am getting an error 



    Detailed Error Information:



    Module
       IIS Web Core 

    Notification
       BeginRequest 

    Handler
       Not yet determined 

    Error Code
       0x80070021 

    Config Error
       This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".  

    Config File
       \\?\C:\hosted\sites\sf_dev_site1\web.config 



    Requested URL
       http://dev.site1.com:80/sitefinity 

    Physical Path
       C:\hosted\sites\sf_dev_site1\sitefinity 

    Logon Method
       Not yet determined 

    Logon User
       Not yet determined 




    Config Source:
      249:     </modules>
      250:     <handlers>
      251:       <remove name="WebDAV" />

    Any Idea what is happening here and how to resolve this
  4. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    22 Apr 2013
    Link to this post
    Hello John,

    At the time when I wrote the reply (01-Mar-2013) Windows Server 2012 was still not officially supported by Sitefinity. 

    It seems that IIS needs to be further configured on your server. Can you please try the suggestions provided in the following thread and let us know of the outcome? Also go through our Documentation on setting up IIS to host Sitefinity projects and make sure that everything is correctly configured.

    Kind regards,
    Pavel Benov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 1 answered