+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / 3.2 SP1 to 3.7 SP3 Upgrade Issue

3.2 SP1 to 3.7 SP3 Upgrade Issue

6 posts, 1 answered
  1. Jason M
    Jason M avatar
    108 posts
    Registered:
    15 Jan 2007
    27 Aug 2010
    Link to this post
    We just upgraded to 3.7 SP3 from 3.2 SP1.  Everything seems to go smoothly, but I noticed an issue with Libraries & Documents.  I can upload images/docs in the modules section and have 400+ items in my Library.  However, if I try to add a link to PDF in generic content I only see 2 items in this library (.xls and .doc files).  I checked the web.config and my Custom Library should work for all extensions.

    <

     

    add name="Custom" title="Custom Library" defaultExtenstions=".*" metaKeys="Author, Description, Extension, Name, Size, Category"></add>

     


    Any ideas?  I tried adding all the relevant entensions in the web.config, but no success.

    We're also using a CustomLibraryProvider to enable granular library security, see the following thread:
    http://www.sitefinity.com/devnet/forums/sitefinity-3-x/bugs-issues/upgrade-from-3-2-sp1-to-3-7-sp3-problem-with-custom-library-provider.aspx 

    Thanks for your help!
    J
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    27 Aug 2010
    Link to this post
    Hi Jason M,

    Thank you for using our services.

    When you have upgraded the project from Sitefinity 3.2 to Sitefinity 3.7 did you check out this KB article linked in the Upgrade Instructions: How to replace urlWhitespaceChar in your Images and Documents library items after upgrade from 3.2 to 3.5? I have tested this behavior in an upgraded project and the document selector is showing all files in custom libraries. Also when you have upgraded the project did you merge the Sitefinity folder from the upgrade patch? This folder contains changed templates of dialogs and backend pages.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Jason M
    Jason M avatar
    108 posts
    Registered:
    15 Jan 2007
    27 Aug 2010
    Link to this post
    Hello Radoslav,

    Thanks for the quick reply.  I read the KB about the whitespaces and copied all the upgrade folders.  For Generic Content Items I'm able to add an image to the page and can see every image.  Just seems to be an issue with adding documents from a Generic Content Item.  Here's the Generic Content reference I have in my web.config:

    <add name="Generic Content" section="Most popular" type="Telerik.Cms.Engine.WebControls.GenericContent, Telerik.Cms.Engine" />

     


    Which files should I try re-copying?  I've done this upgrade on three servers (dev, staging and production), but have the same problem for all.  I suspect this might be an issue with the CustomLibraryProvider I mentioned above.

    J
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    30 Aug 2010
    Link to this post
    Hello Jason M,

    Thank you for getting back to me.

    I have tried to reproduce your issue, however was unable to. Bellow is the list of steps I did to recreate the problem.
    1) Set up a website using Sitefinity 3.2
    2) Create custom type library and upload documents - xls, xml, .docx, .pdf, .xps, etc.
    3) Upgrade the project to Sitefinity 3.7 SP3 .NET 3.5
     - completely merging the files from the upgrade patch
     - merging differences in web.config files

    When the websites was upgraded there were no problems with linking items from custom libraries.

    To move this support request further I will kindly ask you to open a support ticket where you can send us your project along with database. We will set it up locally and run it. This will help us see what might be going wrong.

    Kind regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Jason M
    Jason M avatar
    108 posts
    Registered:
    15 Jan 2007
    30 Aug 2010
    Link to this post
    Its the CustomLibraryProvider.cs file.  I removed this reference from the web.config and it works fine.  I'll submit this file to you in a support ticket.

    Thanks for your help!
    J
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    30 Aug 2010
    Link to this post
    Hello Jason M,

    We will check the support request you have opened and see the attached provider.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
Register for webinar
6 posts, 1 answered