+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / 3.6 sp2 - can't override NewItemEdit

3.6 sp2 - can't override NewItemEdit

6 posts, 0 answered
  1. Chris
    Chris avatar
    10 posts
    Registered:
    30 Apr 2008
    29 Jun 2009
    Link to this post
    Have 'upgraded' to 3.6 sp2.

    We were implementing the News Thumbnail from Images and Documents KB (http://www.sitefinity.com/support/kb/sitefinity-3-x/adding-thumbnails-from-image-and-documents-to-the-news-module.asp) - worked OK before but went wrong after upgrade.

    Went back through the KB and followed instructions - now working fine for NewsItemNew - but not NewsItemEdit (get the 'editor' style image picker with upload options)

    I don't think the override in Telerik.Sitefinity.Configuration.ControlsConfig.xml for NewsItemEdit is working - no chanegd were making it onscreen and to test I changed the entry for it something non-existant and restarted the application, but the Edit page still worked (without throwing an error).

    This the the entry from the ControlsConfig file

    <!--Provides user interface for editing a news item in the News module.--> 
            <viewSettings hostType="Telerik.News.WebControls.Admin.NewsItemEdit" layoutTemplatePath="~/CustomControls/News/Admin/NewsItemEdit.ascx" /> 
            <!--Provides user interface for adding new news items in the News module.--> 
            <viewSettings hostType="Telerik.News.WebControls.Admin.NewsItemNew" layoutTemplatePath="~/CustomControls/News/Admin/NewsItemNew.ascx" /> 

    Any ideas - is this a known issue or unique to me?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    29 Jun 2009
    Link to this post
    Hello Chris,

    The host type for Telerik.News.WebControls.Admin.NewsItemEdit seems to be correct. Generally NewsItemNew and NewsItemEdit views support thumbnail web editor.
    Please try making an change to the web.config file and then access the NewsItemEdit view. Let us know whether the changes you have made to the template are show. Also in the KB is used ButtonSelector control which has its own tempalte.

    We do not have known issues with mapping of the templates. If the problem persists, please write back to us. Additiona information and screenshots will be appreciated.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Chris
    Chris avatar
    10 posts
    Registered:
    30 Apr 2008
    29 Jun 2009
    Link to this post
    hello

    Thanks for reply.

    The issue is that changes (the addition of ButtonSelector and commenting out file 'picker'for thumbnail) are visible and applied to NewsItemNew but not NewsItemEdit. (ButtonSelector itself is fine).

    Have made change to web.config and tried again but same issue.

    What further info do you need?

    C
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    03 Jul 2009
    Link to this post
    Hi Chris,

    Could you send us the templates you are using, ControlsConfig file and some screenshots that describes the problem. I will set up your templates at my end and try to figure out what is going wrong.

    I look forward to hearing from you.

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  5. Chris
    Chris avatar
    10 posts
    Registered:
    30 Apr 2008
    06 Jul 2009
    Link to this post
    Hi Ivan

    Thank for your help - I worked out the issue. Although I was defining the NewsItemEdit template I was overriding it a little later:

    <viewSettings hostType="Telerik.News.WebControls.Admin.NewsItemsView, Telerik.News"
                <views> 
                    <remove name="NewsItemEdit"></remove> 
                    <add name="NewsItemEdit" viewType="CustomNewsItemEdit, App_Code"></add> 
                    <remove name="NewsItemPreview"></remove> 
                    <add name="NewsItemPreview" viewType="CustomNewsItemPreview, App_Code"></add> 
                </views> 
            </viewSettings> 
     
    This part of a solution to an issue with localizing the title field in the initial release of 3.6 (I raised a support ticket which Georgi resolved)

    In CustomNewsItemEdit I added the an override on the LayoutTemplatePath property which solved my problem.
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    06 Jul 2009
    Link to this post
    Hi Chris,

    If you need further assistance, let us know.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
6 posts, 0 answered