+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / A template with the same name already exists

A template with the same name already exists

4 posts, 0 answered
  1. Michael
    Michael avatar
    17 posts
    Registered:
    12 Oct 2008
    27 Jan 2009
    Link to this post
    I am getting the following error anytime I try to edit a template in my site.  I should clarify that I was able to create the template and was able to add one generic content control and one tab strip to two of the 5 separate content placeholders.  I was able to save the template. Now, when I try to add a new control to the template, or when I click the save or cancel button while in edit mode I get the following error....

    1/27/2009 8:46:56 AM [UNKNOWN]
    ************************************************************************************
    ID: add2f0d9-c3b1-41cd-8255-c3a007b1bcb2; Code: 3005; Occurrence: 6; Sequence: 227
    ------------------------------------------------------------------------------------

    Application information:
        Machine name: OFFICE
        OS Version: Microsoft Windows NT 6.0.6001 Service Pack 1
        Product Version: 3.5.1747.2
        Application Path: C:\Program Files\Telerik\Sitefinity3.5\WebSites\MySite\
        Debug: True

    Process information:
        Process ID: 3700
        Process Name: WebDev.WebServer

    Request information:
        Request URL: /MySite/OneColumn.template.aspx?cmspagemode=edit
        Rewrite URL: http://localhost:55712/MySite/OneColumn.template.aspx?cmspagemode=edit
        Url Referrer: http://localhost:55712/MySite/OneColumn.template.aspx?cmspagemode=edit
        Is Authenticated: True
        Authentication Type: Forms
        User: host
        User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 (.NET CLR 3.5.30729)
        User Address: 127.0.0.1

    Variables:
        AspSessionIDManagerInitializeRequestCalled: True
        IsTemplate: True
        cmspagemode: edit
        Sitefinity.UrlChahged: False
        cmspageid: 7028933e-39a9-43dc-84dd-43f4cbb02393
        CmsHttpRequest: /MySite/OneColumn.template.aspx?cmspagemode=edit
        RadControlRandomNumber: 0
        cmshost: Telerik.Cms.Hosting.DesignerHost

    - L0 -------------------------------------------------------------------------------

    Exception Type: System.ArgumentException

    Message: A template with the same name already exists.

    Source: Telerik.Cms.Data

    Stack Trace:
       at Telerik.Cms.Data.PageTemplate.CheckNames()
       at Telerik.Cms.Data.PageTemplate.VerifyObject()
       at Nolics.ORMapper.Base.OdbClassHelper.VerifyClass(IOdbClass cl)
       at Telerik.Cms.Data.PageBase.Nolics.ORMapper.Base.IOdbClass.BeginCommit()
       at Nolics.ORMapper.Base.Transaction.Commit(Boolean fCleanIfSuccess)
       at Nolics.ORMapper.Base.Transaction.Commit()
       at Telerik.Cms.Data.StagedPage.AddControl(String containerId, ICmsWebControl cmsControl, Int32 ordinal)
       at Telerik.Cms.Data.StagedPage.AddControl(String containerId, Type type, Int32 ordinal, String controlId)
       at Telerik.Cms.Data.StagedPage.AddControl(String containerId, Type type, String controlId)
       at Telerik.Cms.Web.UI.ToolBar.AddContol(String controlName, String zoneId, Int32 ordinal)
       at Telerik.Cms.Web.UI.ToolBar.AddContol(String controlName, String zoneId)
       at Telerik.Cms.Web.UI.Toolbox.Button_Command(Object sender, CommandEventArgs e)
       at System.Web.UI.WebControls.Button.OnCommand(CommandEventArgs e)
       at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument)
       at System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)
       at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
       at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    ------------------------------------------------------------------------------------
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    29 Jan 2009
    Link to this post
    Hello Michael,

    We are aware of the problem and have fixed it for the 3.6 release. You should have no problems after upgrading to this version.

    Meanwhile, you can try to remove the template from your project, then to re-add it again. Usually this workaround is fixing the issue.

    Regards,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. J
    J avatar
    1 posts
    Registered:
    04 Nov 2008
    17 Apr 2009
    Link to this post
    Georgi,

    Is there a 3.5 fix or workaround for this issue? Upgrading to 3.6 is not an option at the moment for us. We have created a new template, but it is showing the same errors when trying to add new elements.

    Any help would be appreciated. Thanks,

    Juan
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Apr 2009
    Link to this post
    Hello J,

    Unfortunately there is not fix for this problem under version 3.5. Sometimes removing the template from the project root, restarting IIS and then uploading the template again helps, but this could be just temporarily "solution".

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
4 posts, 0 answered