+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / adding / to a page doesn't cause 404

adding / to a page doesn't cause 404

5 posts, 0 answered
  1. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    28 Nov 2008
    Link to this post
    I think i've discovered a possible bug in your 404 / extensionless URL handling system. If you navigate to an existing correct page url, but append a / to the end of it, instead of trying to locate that path and throwing a 404, it instead returns the correct page. However since the path is not correct, there is a problem with accessing things like graphics and css.

    take a look at what I mean

    http://www.mcallen.net/bridge/bridge-cam.aspx/

    in addition the links to the left also are incorrect because they are no longer relative to the correct path.

    let me know if you need anything else from me to troubleshoot this issue.
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    01 Dec 2008
    Link to this post
    Hello SelArom,

    We reproduced a similar problem.
    Could you please elaborate on what controls you have on the page?

    We have updated your Telerik account with some points.

    Best wishes,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    01 Dec 2008
    Link to this post
    on that page in particular there is an iframe user control that I built... but it happens on pages that have just the build in generic content. It seems to happen on any end page that you add / to.
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    01 Dec 2008
    Link to this post
    Hi SelArom,

    We have logged it to our system.
    In order to prevent it, you may define:
    1. Url rewrite rules that match an url different than the home page, and containing a slash at the end. If such request is found, then you should be redirected to the matched url without the slash.
    2. Http module doing the same.

    We will try to fix it as soon as we can. Thank you once again!

    Sincerely yours,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  5. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    01 Dec 2008
    Link to this post
    in the few months our site has been live I've only received this error once, so I think we'll be ok to wait for the fix. thanks for keeping me posted :)
Register for webinar
5 posts, 0 answered