+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Admin site javascript errors - RadTabStrip is undefined after project upgrade to vs2010 .net 4.0

Admin site javascript errors - RadTabStrip is undefined after project upgrade to vs2010 .net 4.0

6 posts, 0 answered
  1. Dean
    Dean avatar
    2 posts
    Registered:
    14 Jun 2010
    14 Jun 2010
    Link to this post
    I upgraded my webforms/commerce server/sitefinity 3.6 project to VS 2010/.NET 4.0/ASP.NET 4.0. The actual content site seems to work fine, but the Sitefinity admin site has several javascript errors when I go the the Pages section:
    SiteMapPanel is undefined
    RadTabStrip is undefined
    RadMultiPage is undefined
    RadTreeView is undefined
    CMSPageViewer is undefined

    This renders all of the page links in the left strip inoperable and if I do open a page by digging through the table of pages, then the properties button is inoperable. Obviously an unacceptable condition.

    This is a showstopper, so any help is welcome.

    Thanks,
    Dean Wise
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    14 Jun 2010
    Link to this post
    Hello Dean,

    Thank you for using our services.

    Sitefinity 3.x does not support .NET 4.0 framework. The issues you are experiencing are from compatibility problems between our code and the framework. We have planned another service pack for Sitefinity 3.7 which will support .NET 4.0. This release is expected sometime in August.

    Kind regards,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Jimmy
    Jimmy avatar
    3 posts
    Registered:
    04 Jul 2012
    28 Sep 2010
    Link to this post
    Hello,

    I am also receiving the 'cmspageviewer' is undefined error when selecting a template in Sitefinity 3.7 SP4.  I am using the native .net 4.0 version of Sitefinity also.

    Any ideas?
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    28 Sep 2010
    Link to this post
    Hello Jimmy,

    Can you please make sure there have been no changes in the ClientIDMode setting in web.config?

    Kind regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Jimmy
    Jimmy avatar
    3 posts
    Registered:
    04 Jul 2012
    28 Sep 2010
    Link to this post
    Hello Radoslav,

    My ClientIDMode reads as follows on both of my web servers in load balanced configuration:

    <pages clientIDMode="AutoID" controlRenderingCompatibilityVersion="3.5">


    It had previously read:

    <pages clientIDMode="AutoID" controlRenderingCompatibilityVersion="3.5" enableEventValidation="false">


    As it was suggested that the enableEventValidation = false tag was required for load balanced Sitefinity installations, but this caused me errors.

    Since it was removed both web servers have had hard resets, iisresets and I've double checked that the properties are correct now.

    Any ideas?
  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    29 Sep 2010
    Link to this post
    Hi Jimmy,

    Thank you for getting back to me.

    Can you please try using Fiddler to see if requests to WebResource.axd and ScriptResource.axd throw 404 errors?
     
    Greetings,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
6 posts, 0 answered