+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / After Upgrade to 3.5 - Get Trial Version Message

After Upgrade to 3.5 - Get Trial Version Message

25 posts, 0 answered
  1. Justin
    Justin avatar
    9 posts
    Registered:
    05 Sep 2007
    14 Jan 2009
    Link to this post

    We just upgraded from 3.2 to 3.5 and now receive a "You are running a trial version of SiteFinity 3.5" message when someone accesses a page. We did place the xml license file in the SiteFinity Folder. Can you help?

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    16 Jan 2009
    Link to this post
    Hi Justin,

    Could you tell us which domain you are referring to? As I see it from your account you have not generated any license keys. Open a support ticket if possible or contact our sales department.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. Rachel Fernandez
    Rachel  Fernandez avatar
    1 posts
    Registered:
    02 May 2008
    24 Mar 2009
    Link to this post
    We are having this same problem.  Can you share what solution you offered to Justin?
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    25 Mar 2009
    Link to this post
    Hi Rachel Fernandez,

    I sent a reply to your support request with some description. I have not received reply form you yet.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
  5. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    27 May 2010
    Link to this post
    Ivan Hi,

    Recently, we got a 'Trial' message on one of our fully licensed Sitefinity Standard Edition systems. Why would that be? I believe it is version 3.6.

    Thanks

    Andrei
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    27 May 2010
    Link to this post
    Hello Andrei,

    Here is a KB that explains some of the general reasons for a trial message   running a trial version of Sitefinity

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  7. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    14 Jun 2010
    Link to this post
    Ivan,

    I have checked your posts, just to let you know that the trial message has come up again.

    The Page Source shows 3.6.1936.2:1 yet the message still comes up. I have restarted the servers that host the web app. It comes up very rarely (months) but there is no heavy usage though. I have checked the spelling in the LicenseFile.xml and all.

    What would you suggest next. Can this be a bug?

    Thanks,

    Andrei
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    14 Jun 2010
    Link to this post
    Hi Andrei,

    Move the LicenseFile.xml in your App_Data folder and modify your web.config - cms node to set the new path of the license file as shown below. Restart the application again


    <cms  defaultProvider="Sitefinity" licenseFile="~/App_Data/LicenseFile.xml ......

    Make sure that you are not making any internal network forwarding that alters the host header. The key uses host header to identify the domain

    Regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  9. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    15 Jun 2010
    Link to this post
    Ivan,

    Ok, I moved the LicenseFile.xml from ~/Ids/Sitefinity/LicenseFile.xml to ~/Ids/App_Data/LicenseFile.xml where 'Ids' is the web application name.

    I have changed the ~/Ids/Web.config file: <cms defaultProvider="Sitefinity" licenseFile="~/App_Data/LicenseFile.xml" pageExtension=".aspx" projectName="IDS"
          disabled="false" pageEditorUIMode="Overlay">

    Currently the LicenseFile.xml is in two locations. I did not delete it from the ~/Ids/Sitefinity/LicenseFile.xml location just in case. Should I?

    Should I restart the Server just in case?

    Also,can you elaborate on your previous point: "Make sure that you are not making any internal network forwarding that alters the host header. The key uses host header to identify the domain" please.

    Now we will monitor it and see if it keeps coming up. Not sure why it would show when the Page Source shows that it has picked up on the license file???

    Many thanks,

    Andrei
  10. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    15 Jun 2010
    Link to this post
    Hello Andrei,

    You can try this code to check the server name:
    HttpContext context = HttpContext.Current;
    string serverName = context.Request.Url.Host;

    Make sure that the license file has the correct structure:
    <?xml version="1.0" encoding="utf-8" ?>
    <root>
        <license control="cms" company="xxx" licenseKey="xxx" />
    </root>

    Greetings,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  11. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    15 Jun 2010
    Link to this post
    Radoslav,

    I can just go to: My Computer (right click) -> Properties -> Computer Name and check it like that. We have two Web Servers (MET-A and MET-B) which are Load Balanced for redundancy purposes, in case one dies.

    Terminals are then accessing them via the load balancing Domain Name which is the same as the one used to generate the license key.

    The license file is ok if it picks it up in the Page Source. i checked it anyway and it is fine.

    I have implemented what Ivan suggested above and now waiting to see if the Trial message re-appears.

    Many thanks,

    Andrei
  12. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    15 Jun 2010
    Link to this post
    Hi Andrei,

    If your web servers do not use the same files - the website source is not on a network share, but rather each server has its own version of the files, please make sure that both sources contain the license file.

    Sincerely yours,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  13. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    15 Jun 2010
    Link to this post
    Radoslav,

    Yes, each server has its own local copy of the web application with its own licence file as well. Nothing is shared. I checked and made sure they are all identical on both sides.

    So unless you guys can think of anything else then we will wait to see if it reappears.

    Many thanks,

    Andrei
  14. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    16 Jun 2010
    Link to this post
    Hi Andrei,

    Lets wait and see if you will get he error message.

    Sincerely yours,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  15. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    02 Sep 2010
    Link to this post
    Radoslav,

    The issue has come up again today. All  the clients (8 of them) were restarted at once and when they came up, one of the clients showed the trial message.

    Questions:

    1 - Could it be because of the contention over reading the license file? My opinion, is "Not likely".
         So far, the trial message has happened only when restarting the clients.

    2 - How often is the trial message supposed to come up, usually? It comes up very rarely.
         Should we have another look at the license key. Maybe it got generated wrongly?

    3 - If a page has been developed under a trial version of Sitefinity and then stored in the
         database. Then the page is accessed under a fully licensed version of sitefinity, could
         that be the problem?

    Thanks;
    Andrei
  16. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    02 Sep 2010
    Link to this post
    Hello Andrei,

    This is really strange. Due to some reason the license key could not be read or there is a temporarily network routing  that you make. The license key is checked before initialization of all modules by CmsHttpModule.

    1 - Could it be because of the contention over reading the license file? My opinion, is "Not likely".
         So far, the trial message has happened only when restarting the clients.

    You could try to put the key in App_Data folder and set licenseFile property in <cms> node of the web.config to ~/App_Data/LicenseFile.xml


    2 - How often is the trial message supposed to come up, usually? It comes up very rarely.
         Should we have another look at the license key. Maybe it got generated wrongly?

    The trial message appears randomly within 50 requests. I suggest that you should check your license keys through Sitefinity >> Account section.

    3 - If a page has been developed under a trial version of Sitefinity and then stored in the
         database. Then the page is accessed under a fully licensed version of sitefinity, could
         that be the problem?

    This could not be the issue and there is no relation between the objects create under trial mode and licensed mode.

    If the problem persist you can contact our sales department to verify the keys you have.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  17. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    03 Sep 2010
    Link to this post
    Ivan,

    "You could try to put the key in App_Data folder and set licenseFile property in <cms> node of the web.config to ~/App_Data/LicenseFile.xml"
    Please check through the past posts, I think I have already tried that.

    Attached is a rough system diagram for your information. Ooops, it only allows images. Ok, will email it to you,
    if I could have the email address.

    I am going to carry out some more tests on it today and get back to you on Monday with the results.

    We really need to sort it out, or think again about using Sitefinity for subsequent systems.
    We can't have that. It does not look good when the customer sees that message.

    Many thanks again,
    Andrei
  18. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    03 Sep 2010
    Link to this post
    Hi Andrei,

    Ok, open support or sales request and tell us the websites, account owner and license keys you use and we will debug the keys to see if they pass through our code. Reading the license file is forced when the application is restarted and your key is not valid/set or somehow the host is changed.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  19. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    03 Sep 2010
    Link to this post
    Ivan,

    Because we develop systems for the Air-Traffic community, the systems are closed and not available for
    access via the internet. We use Sitefinity for the customers to manage their content on a closed LAN.

    I can send you the license key file, the name of my collegue who purchased it (since the account is under his name, i am the developer), the domain name, the system diagram, and all. 

    We purchase the license, set up the system, test it, deliver it, rebuild it, test it again, and by that time a year has gone. Which makes it a bit difficult for me to submit a ticket now. The only way I can contact you now is via the forum.

    I am at a bit of a loss...

    Many thanks,
    Andrei
  20. Grisha 'Greg' Karanikolov
    Grisha 'Greg' Karanikolov avatar
    156 posts
    Registered:
    30 Nov 2016
    03 Sep 2010
    Link to this post
    Hi Andrei,

    Let me try assisting you here. Please send me the license key file, the domain name you are using for your website and the name of the license owner (preferably his e-mail address as well) so that I can take a look if I could find something on my end.

    You can e-mail me at greg@telerik.com. Looking forward to your reply!

    All the best,
    Grisha Karanikolov
    Sitefinity Sales team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  21. Jose Antonio
    Jose Antonio avatar
    13 posts
    Registered:
    19 Jul 2010
    14 Jan 2011
    Link to this post


    Hi, I have the same problem, i followed all the instructions above and my site continue showing the trial message, could you help me, please?

    Thanks, José Antoñito.
  22. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    17 Jan 2011
    Link to this post
    Jose,

    If you are still within the support time and tried everything then get in touch with Greg.

    Let me try assisting you here. Please send me the license key file, the domain name you are using for your website and the name of the license owner (preferably his e-mail address as well) so that I can take a look if I could find something on my end.
    You can e-mail me at greg@telerik.com. Looking forward to your reply!

    Else,
    1 - Double-check the Page Source and see if the license file is read properly by Sitefinity.
    2 - Double-check the license file again with the one online. Make sure there are no mistakes. The company needs to be written correctly and no additional spaces.
    3 - Make sure access rights are correct to the file location.
    4 - Make sure your Load Balance is configured correctly and you are accessing it correctly.
    5 - Make sure you restart everything after updating things just in case. You should not have to but I would do it anyway.
    6 - Search all forums, there are bits hidden sometimes that could prove very helpful.

    Sorry...
    Andrei
  23. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Jan 2011
    Link to this post
    Hello,

    Please check this KB and verify that you are not changing the host for the current request.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  24. Jose Antonio
    Jose Antonio avatar
    13 posts
    Registered:
    19 Jul 2010
    17 Jan 2011
    Link to this post
    Actually i checked the KB you mention before, i'm really confused because i don't understand what is the problem. I sent a e-mail to Greg.
    Thanks.
  25. Jose Antonio
    Jose Antonio avatar
    13 posts
    Registered:
    19 Jul 2010
    17 Jan 2011
    Link to this post
    I sent you an e-mail. 
    Thanks for the atention.
Register for webinar
25 posts, 0 answered