+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Blog search results

Blog search results

4 posts, 0 answered
  1. Julia Shah
    Julia Shah avatar
    13 posts
    Registered:
    03 Sep 2012
    05 Oct 2009
    Link to this post
    Hi,

    We have a blog on our website that is published on www.domainname.com/clients/blog.aspx. It is configured to show BlogPosts control in "Auto" mode, so when I click on a post's title, I am sent to www.domainname.com/clients/Blog/yy-mm-dd/SomePostTitle.aspx?ReturnURL=%2fClients%2fBlog.aspx&CntPageID=1.

    I also have a blog search page. The problem is that in search results the links look like this: www.domainname.com/clients/Blog/BlogPost/yy-mm-dd/SomePostTitle.aspx. It works for posts that have CntPageID=1, but not for posts where CntPageID is 2 or 3. What is CntPageID? I've tried to remove "CntPageID" from the PageKey QueryString Keys in the BlogPost control's settings, but it comes back. What else can I try to fix the problem?

    Thanks,
    Julia
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    08 Oct 2009
    Link to this post
    Hi Julia Shah,

    Thank you for contacting us.

    CntPageID is used in the query string to hold the page number, when you have paging enabled. Usually there should not be any problem with this, since the SearchResults control should take you to the blog post directly. Of course, there is no paging at all on the blog post page.

    Can you please try the following:
    Set the following properties:
    • ContentItemKeyPersistance to false (Query String keys section)
    • ReturnUrlPersistance to false (Explicit Links section)
    • AllowLinksToPrevNextItem to false (Explicit Links section)
    If this doesn't help, we would like to check your web site settings. Just let us know if this is an option, we will contact you with the details. 

    Kind regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Julia Shah
    Julia Shah avatar
    13 posts
    Registered:
    03 Sep 2012
    08 Oct 2009
    Link to this post
    Hi,

    Thank you for reply. I don't see ContentItemKeyPersistance and ReturnUrlPersistance properties, I guess it's new? (We are using Sitefinity 3.2). But I changed AllowLinksToPrevNextItem to false, and it fixed the problem.

    Thnak you for your help!
    Julia
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    08 Oct 2009
    Link to this post
    Hello Julia,

    Thank you for letting me know about the state of the issue.

    Yes, the mentioned properties are new ones. I thought that you are using the current version, since this is what is written in the ticket information, but agree that had to ask if this is the case - apologies for that!

    I am glad that the solution worked for you.

    Let me know if I could be of any further help!

    Best wishes,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Register for webinar
4 posts, 0 answered