+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Bug with categories list

Bug with categories list

12 posts, 0 answered
  1. Paul
    Paul avatar
    176 posts
    Registered:
    18 Nov 2008
    23 Jun 2009
    Link to this post

    Hi!

    I found some strange bug in categories list behavior: when I add new category and after this I add some generic_content item to this category It doesn't show me new category in categories list and when I try to open content of this category It shows me empty page whithout any content. I found that only adding other category with same name (but shorty) can help in this case. What can cause this? 

  2. Stoyanka Assenova
    Stoyanka Assenova avatar
    113 posts
    Registered:
    01 Dec 2016
    25 Jun 2009
    Link to this post
    Hi Paul,

    We know for this problem. This is a cache problem with Category List control. If you reset IIS, this problem disappear. This problem does not exist for Categories Tree control. We would recommend you to use it instead of the CategoriesList.

    If you have any problems, you do not hesitate to contact us.

    Regards,
    Stoyanka Assenova
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Paul
    Paul avatar
    176 posts
    Registered:
    18 Nov 2008
    25 Jun 2009
    Link to this post

    Hi Stoyanka!

    You wrote that this problem does not exist for Categories Tree control but I have this problem  and I use only Category Tree control. Category List control did not help me to create functionality which my customer wants. Maybe this bug can be connected with levels of categories and It can work only with 1st level categories?

    Thank you.

  4. Stoyanka Assenova
    Stoyanka Assenova avatar
    113 posts
    Registered:
    01 Dec 2016
    25 Jun 2009
    Link to this post
    Hello Paul,

    We cannot reproduce this problem locally. By design in Categories Tree control displays all categories that use in content items. If category does not use in content items, this category does not appear in Categories Tree control. Please, could you send your database, master pages and web.config file.

    Thanks for your cooperation in advance.

    Kind regards,
    Stoyanka Assenova
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  5. Paul
    Paul avatar
    176 posts
    Registered:
    18 Nov 2008
    26 Jun 2009
    Link to this post

    Hi Stoyanka!

    I can reproduce what I'm doing. I have one main category and a lot of subcategories with content linked to them. I use category tree control on page and set the property Root Category to name of main category. Some categories shows perfect but two or three last categories does not show. They become showing when I add categories with same name as this categories but shorter.

    I can't send you my database because It's large. Can you help me in fixing this problem or this is a bug which you will fix in next versions?  

  6. Stoyanka Assenova
    Stoyanka Assenova avatar
    113 posts
    Registered:
    01 Dec 2016
    29 Jun 2009
    Link to this post
    Hello Paul,

    We cannot reproduce this problem locally.
    Please, could you send to us the screen shots with Categories tree from admin part and public part and write which category does not show. Which Version of Sitefinity you use?

    Thank for your cooperation in advanced.

    All the best,
    Stoyanka Assenova
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  7. Paul
    Paul avatar
    176 posts
    Registered:
    18 Nov 2008
    29 Jun 2009
    Link to this post

    Hi Stoyanka!

    You can see screenshots here:

    On site - http://jurfak.spb.ru/Libraries/6681227b-1d7d-43ed-bc20-e6836f4f8ac5.sflb.ashx

    Admin interface - http://jurfak.spb.ru/Libraries/7473d1ba-aee6-4f26-8f11-20badc9850a6.sflb.ashx  

    I am using Sitefinity 3.6.1927.2:1. 

  8. Stoyanka Assenova
    Stoyanka Assenova avatar
    113 posts
    Registered:
    01 Dec 2016
    29 Jun 2009
    Link to this post
    Hi Paul,

    Thank you for the screen shots.
    These 2 categories ("Рейтинг на 26 июня 2009г" - count zero, "Рейтинг на 27 июня 2008г" - count zero) do not appear in Categories Tree in the public part, because you do not use these categories in the content items. The Categories Tree control displays all categories that are used in content items. Once you have a content item in this category, it will be shown in the control as well.

    Hope this helps.

    Regards,
    Stoyanka Assenova
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  9. Paul
    Paul avatar
    176 posts
    Registered:
    18 Nov 2008
    29 Jun 2009
    Link to this post

    Hi Stoyanka!

    Now you can see this bug. I have wrote a lot about this bug in my previous posts. You can see on scr1.jpeg that I have created two categories with same names: "Рейтинг на 26 июня 2009 года" and "Рейтинг на 26 июня 2009г". This was done becuase If I delete category with short name my category with content and long name will dissapear from site. For categories "Рейтинг на 27 июня 2008 года" and "Рейтинг на 27 июня 2008г" problem is the same. What can you say about this?

    Thank you.

  10. Stoyanka Assenova
    Stoyanka Assenova avatar
    113 posts
    Registered:
    01 Dec 2016
    30 Jun 2009
    Link to this post
    Hello Paul,

    This is not a bug. This is by design. I wrote in my previous post that the Categories Tree control displays all categories that are used by the content items you have. In the screen shot that you sent me, the count for the category "Рейтинг на 27 июня 2008г" is zero. This is the reason why  the category "Рейтинг на 27 июня 2008г" does not appear in the public part.
    Did you set ShowRootCategory=true and RootCategory = Рейтинг Студентов in the Categories Tree control (see the attachment)?

    Regards,
    Stoyanka Assenova
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  11. Paul
    Paul avatar
    176 posts
    Registered:
    18 Nov 2008
    30 Jun 2009
    Link to this post

    Hello Stoyanka!

    This is not by design =). I read a lot about category tree control and know how configure this control. Yes I  set as RootCategory = "Рейтинг студентов" but also I set property ShowRootCategory="false". In my other pages on web site Categories Tree control works fine with same properties. Problems appear only with this categories. I describe you once more time this problem which cannot be resolve by configuration Category Tree control in Admin Interface:

    As you can see I have a root category "Рейтинг студентов" which I use in property RootCategory of my Categories Tree control. My last added category ("Рейтинг на 27 июня 2008 года") does not show on site but It has some linked content. I found that adding other category without content but with same shorter name ("Рейтинг на 27 июня 2008г") fixed all. If I add after this new category It also does not show on site. I need to add other empty category to show my category with content on site.

    At the first time I also think that this is design bug but when I look on source of my page I have not found any category which should be shown (I thought that It does not shown because Root Category take It place on div and this category lie below).

    Thank you. 

  12. Stoyanka Assenova
    Stoyanka Assenova avatar
    113 posts
    Registered:
    01 Dec 2016
    30 Jun 2009
    Link to this post
    Hello Paul,

    Thank you for the detailed information about this problem. We reproduced it. Your Telerik points has been updated.
    Work around: If you set ShowRootCategory=true in the Categories Tree control, it will work just fine.

    We are sorry for the inconvenience caused.

    All the best,
    Stoyanka Assenova
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
12 posts, 0 answered