+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Can't login with IE when using http://computername

Can't login with IE when using http://computername

10 posts, 0 answered
  1. MNP
    MNP avatar
    79 posts
    Registered:
    23 Apr 2008
    17 Dec 2008
    Link to this post
    We're testing Sitefinity here internally and I have it installed on my machine. We've created several users and can log in with no problems when using http://localhost

    When i change the URL to be http://computername the web site loads of for other users, however we can only seem to login with Firefox. With IE, the login page loads up, but after submission, it either refreshes, or returns back to the previous page you were at if the page required authentication.

    Can we do this for testing? Run the website from my local machine before pushing up to a "normal" server?

    Thanks

    -Matt
  2. Nikolai
    Nikolai avatar
    216 posts
    Registered:
    21 Nov 2016
    18 Dec 2008
    Link to this post
    Hello Matt,

    This is a very strange problem.
    Could you send us the hosts file located in ~\Windows\System32\drivers\etc?
    For your second question - There should be no problem to do test locally just have this in mind: when adding links to a content(Generic_Content etc...), make sure that the links do not contain http://localhost. Otherwise they might be broken after publishing to the live environment.

    All the best,
    Nikolay
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. MNP
    MNP avatar
    79 posts
    Registered:
    23 Apr 2008
    18 Dec 2008
    Link to this post
    The only uncommented line in the hosts file is:

    127.0.0.1       localhost

    I should mentioned that even for myself, on my computer if I go to http://computername I can't log in with IE. I only am connecting to SQL Server Express 2008 on my machine.

    Thanks for the help. I'm always amazed by the high quality responses one gets from Telerik.

    -Matt

  4. Nikolai
    Nikolai avatar
    216 posts
    Registered:
    21 Nov 2016
    19 Dec 2008
    Link to this post
    Hello Matt,

    It seems that there is a problem with IE 7 blocking the cookies. Can you please check the Privacy tab in the IE(see the attachment) and change the security level? You may also try to add your computer name to the hosts file, just like how the localhost entry.

    Best wishes,
    Nikolay
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  5. MNP
    MNP avatar
    79 posts
    Registered:
    23 Apr 2008
    19 Dec 2008
    Link to this post
    So the problem actually is that IE7 won't accept cookies from hosts that have an underscore in them. My computer name is named PC_14587. If we type in the ip address then eerything works as it should.

    http://social.msdn.microsoft.com/forums/en-US/iewebdevelopment/thread/666533ab-6634-4be5-a6d9-9b7239ed967f

    Silly Microsoft...why must you be so difficult!

    Thanks for all your help once again.

    -Matt
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    19 Dec 2008
    Link to this post
    Hello Matt,

    Thank you very much for your follow up!

    Reading the post till the end I saw this: "...looked it up in the DNS RFCs and underscores are indeed not allowed in domain name labels."

    I should admit that I would never think for a reason like this one.

    Sincerely yours,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  7. Jaycen
    Jaycen avatar
    13 posts
    Registered:
    29 Dec 2008
    29 Dec 2008
    Link to this post
    Hi, guys.

    I've run into a similar problem using IE to edit sitefinity pages.  It's been working for me on this laptop for a couple months, but when we went to multi-lingual support, IE won't show me the content of a page.  It always shows up as a gray screen, when I first select the page from the list on the Site Map.

    If I click the button that says "Edit this page in English" IE chugs forever and never comes up with anything.  I've been editing in FireFox for the last couple weeks.

    Not sure if this is related.  Already check and my PC name contains no underscores.
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    30 Dec 2008
    Link to this post
    Hello Jaycen,

    Probably, the problem at your end is not related with the computer name. Are you able to work in IE using http://localhost/ ?

    We have not encountered this problem working with IE 7, FF 3, Chrome.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  9. Jaycen
    Jaycen avatar
    13 posts
    Registered:
    29 Dec 2008
    19 Feb 2009
    Link to this post

    Ivan,

    Turns out it was an Add-on that was the source of my problem.  I didn't methodically turn them off till I found the culprit, I just turned off anything that I didn't know or immediately recognize.

  10. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    20 Feb 2009
    Link to this post
    Hi Jaycen,

    I am glad to hear that everything works fine now.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
10 posts, 0 answered