+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Error adding new news item

Error adding new news item

6 posts, 0 answered
  1. Bryce Duncan
    Bryce Duncan avatar
    3 posts
    Registered:
    01 Oct 2009
    01 Oct 2009
    Link to this post
    Using version 3.5:

    When clicking 'Create a new item' in Modules->News->News Items:  The New Item page loads with the exception of the Content section, which seems to encounter a script error that prevents it from fully loading (getting the exclamation sign in the bottom left of IE that says 'Error on page.').  The error is a generic 'Syntax error'.  I cannot place the cursor anywhere in the Content section.

    Not sure if it's related, but the ParentId in the URL query string is all zeroes (ParentId=00000000-0000-0000-0000-000000000000).  Thanks for any help.

    Thanks,
    Bryce

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    01 Oct 2009
    Link to this post
    Hi Bryce Duncan,

    The Parent ID value is correct, because content items created under news provider do not have parent. Most probably you have changed something into ControlPanelInsert or ControlPanelEdit templates. You can check the error log and see if there is the actual error with a stack trace.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Bryce Duncan
    Bryce Duncan avatar
    3 posts
    Registered:
    01 Oct 2009
    01 Oct 2009
    Link to this post
    Thanks Ivan.  Where would I find the error logs?  I am a new user, so excuse my ignorance.

    I've just noticed that when trying to navigate folders in the file viewer, I also get a script error that says 'FoldersNavigation' is undefined.

    Thanks,
    Bryce
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    01 Oct 2009
    Link to this post
    Hello Bryce Duncan,

    The error Log is located under App_Data folder ( sitefinity.log). Check whether you have made any modifications to the News templates. We are not able to reproduce the problem locally. It is possible that you have some js code that does not work correctly and block the loading of all items.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. Bryce Duncan
    Bryce Duncan avatar
    3 posts
    Registered:
    01 Oct 2009
    22 Oct 2009
    Link to this post

    There have been no changes made to the News templates.   I've also noticed we get a similar error when clicking on the 'Files' menu at the top of Sitefinity.  It displays the folders correctly, but I cannot click on them in the left side navigation.  I tried this out via IE8 and it gave a bit more descriptive error message:

    --------------------------------------------------------------------------------------------------------------------------------------------

    Error when adding or editing a news module:

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2)
    Timestamp: Mon, 19 Oct 2009 14:39:00 UTC

    Message: Syntax error
    Line: 1
    Char: 1
    Code: 0
    URI: http://www.wrg-ins.com/ScriptResource.axd?d=_dVtkY2kgY7L6KTXwuujZlfrcOEgbISK7BsP8SzvKvpyYFlOBstqwWScWXs4Nmxv6K0YmcGnekDOBU8nGK--Eg2&t=ffffffffef063c1e

    Message: Object doesn't support this property or method
    Line: 5
    Char: 32821
    Code: 0
    URI: http://www.wrg-ins.com/ScriptResource.axd?d=2SF1J6LtohTaLvKwJhrv3XfHo4fiMSJba5padR-C3mMUevBiaC0_lbxCfZW75D_hHKoVwFT0XZOX3yAoZG3C2Sn4ktyT63AweqNlpYemkTQ1&t=ffffffffd2ae5cf2

     

    --------------------------------------------------------------------------------------------------------------------------------------------

    Error when trying to navigate site files via the 'Files' menu:

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2)
    Timestamp: Mon, 19 Oct 2009 14:40:30 UTC

    Message: Syntax error
    Line: 1
    Char: 1
    Code: 0
    URI: http://www.wrg-ins.com/WebResource.axd?d=EDfyi2kfIqEWTfEg-olueVx1DcSTxQ-5LNkAXHXoq4AvJYbZf4PCneAgvdoEf9nzLMYisfvEzUjNwT03cQ3xhN0TQjn9RvVNj17faUm696doTS1JI--HUiFautIKaixJ0&t=633706532740000000

    Message: 'FoldersNavigation' is undefined
    Line: 234
    Char: 196
    Code: 0
    URI: http://www.wrg-ins.com/SiteFinity/Admin/Files.aspx

     ------------------------------------------------------------------------------------------------------------------------------------------

    This problem only occurs on our production servers, we have a staging site that works fine.  Thanks for any help.

  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    22 Oct 2009
    Link to this post
    Hi Bryce Duncan,

    One of the error is thrown from MicrosoftAjax js, the another one FoldersNavigation seems to be internally thrown. Can you check ( using FireFox - fire bug, IE - debugger, fiddler) whether something stops the scripts or there is a missing script. You can also compare the files between both the servers and see whether you have missed to synchronize something.

    Let us know how it goes.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Register for webinar
6 posts, 0 answered