+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Error: Cannot find url Parameter name: StartingNodeUrl

Error: Cannot find url Parameter name: StartingNodeUrl

2 posts, 0 answered
  1. Menderes Demir
    Menderes Demir avatar
    2 posts
    Registered:
    04 May 2010
    04 May 2010
    Link to this post
    Hi,

    I have changed the webconfig file to enable an extra language (main language: Dutch, extra: English), this without any problems. But after trying to edit a page in the second language (English) i'm getting this error:

    Cannot find url
    Parameter name: StartingNodeUrl

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentException: Cannot find url
    Parameter name: StartingNodeUrl


    Stack Trace:

    [ArgumentException: Cannot find url
    Parameter name: StartingNodeUrl]
       UserControls_Nav_SiteTabstrip.GetStartingNode() +544
       UserControls_Nav_SiteTabstrip.Page_Load(Object sender, EventArgs e) +481
       System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14
       System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +35
       System.Web.UI.Control.OnLoad(EventArgs e) +99
       System.Web.UI.Control.LoadRecursive() +50
       System.Web.UI.Control.AddedControl(Control control, Int32 index) +265
       System.Web.UI.ControlCollection.Add(Control child) +80
       Telerik.Cms.Web.PreviewPage.CreateChildControls() +883
       System.Web.UI.Control.EnsureChildControls() +87
       System.Web.UI.Control.PreRenderRecursiveInternal() +44
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +842
    

    I hope this is enough information to understand and help me with the problem,

    Thanks,
    Menderes Demir
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    04 May 2010
    Link to this post
    Hi Menderes Demir,

    The issue you are experiencing i because you have set the SiteTabStrip to start the nodes it is going to show from a page which is not available in your second language. To fix this, please go you your default language and check the SiteTabStrip control (it may be in your Template) from which page it is set to start. Then create a language version for this page in the second language.

    Best wishes,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
2 posts, 0 answered