+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Events Templates missing some elements

Events Templates missing some elements

9 posts, 0 answered
  1. Damir
    Damir avatar
    22 posts
    Registered:
    24 Nov 2008
    21 Oct 2009
    Link to this post
    I have downloaded Sitefinity_3_7_2022_community_ExternalTemplates and when i am trying to design the events templates they are simply not the same as the standard embedded ones. The pagination is not working in the external ones and fields are missing.

    The 2 Expandable list template are missing from external folder?

    I have another question why do some modules templates can be mapped to an external template using Telerik.Sitefinity.Configuration.ControlsConfig.xml

    and someones like Events cant i tried to map it and its not working they only worked using appearance view in advanced tab - SingleItemTemplatePath?

    When will the Version 4 be out, and what would be done by external templates for 4.0 ?

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    21 Oct 2009
    Link to this post
    Hello Damir,

    Please use Mode templates - ListPageMaster and ListPageDetails. They are located under Sitefinity/Admin/ControlTemplates/Events/Modes folder of the external templates archive.

    There are two possible ways to map an Presentation mode template

    1. Through ControlDesigner
    2. Through SingleItemTemplatePath and ItemListTemplatePath properties of EventsView's Advanced tab.

    You can take a look at the following post for more detailed information - Working with presentation modes.

    Let us know if there is anything else that we can do for you.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Damir
    Damir avatar
    22 posts
    Registered:
    24 Nov 2008
    22 Oct 2009
    Link to this post
    I believe that events don't work when mapping them with ControlDesigner.  Can someone confirm this?
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    22 Oct 2009
    Link to this post
    Hello Damir,

    Mapping the events templates - ListPageMaster and ListPageDetails works on 100 percent. Currently no one has reported any problem if the mapping steps are followed correctly.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. Damir
    Damir avatar
    22 posts
    Registered:
    24 Nov 2008
    22 Oct 2009
    Link to this post
    Ok i have put this into the Telerik.Sitefinity.Configuration.ControlsConfig.xml

    and its not mapping to those templates. It maps to embedded ones

     <viewSettings hostType="Telerik.Events.WebControls.Admin.GeomappingEditor" layoutTemplatePath="~/App_Master/GadgetsTemplates/ControlTemplates/Events/GeomappingEditor.ascx" /> 
        <!--Events View Designer Template--> 
        <viewSettings hostType="Telerik.Events.WebControls.Design.EventsViewDesigner" layoutTemplatePath="~/App_Master/GadgetsTemplates/Admin/ControlTemplates/Events/EventsViewControlDesigner.ascx" /> 
        <!--Time Selector Template--> 
        <viewSettings hostType="Telerik.Events.WebControls.Design.Selectors.TimeSelector" layoutTemplatePath="~/App_Master/GadgetsTemplates/ControlTemplates/Events/TimeSelectorTemplate.ascx" /> 
        <!--Gets or sets the url to EventsScheduleView template.--> 
        <viewSettings hostType="Telerik.Events.WebControls.EventsScheduleView" layoutTemplatePath="~/App_Master/GadgetsTemplates/ControlTemplates/Events/EventsScheduleView.ascx" /> 
        <viewSettings hostType="Telerik.Events.WebControls.EventsView"
          <additionalTemplates> 
            <!--Item List--> 
            <add key="ItemListTemplatePath" layoutTemplatePath="~/App_Master/GadgetsTemplates/ControlTemplates/Events/ContentViewItemView.ascx" /> 
            <!--Single Item--> 
            <add key="SingleItemTemplatePath" layoutTemplatePath="~/App_Master/GadgetsTemplates/ControlTemplates/Events/ContentViewSingleItemView.ascx" /> 
          </additionalTemplates> 
        </viewSettings> 
        <viewSettings hostType="Telerik.Events.WebControls.Rss.RssSettingsControl" layoutTemplatePath="~/App_Master/GadgetsTemplates/Admin/ControlTemplates/Events/RssSettingsControlTemplate.ascx" /> 
        <viewSettings hostType="Telerik.Events.WebControls.Rss.RssViewControl" layoutTemplatePath="~/App_Master/GadgetsTemplates/Admin/ControlTemplates/Events/RssViewSettingsControl.ascx" /> 
         

  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    23 Oct 2009
    Link to this post
    Hello Damir,

    Did you restart your web site. The mappings do not take effect until you restart the web site. Furthermore of the Events View control you should use the templates that are located in ~/Sitefinity/Admin/ControlTemlates/Events/Modes in the external templates archive. All external templates for the Events module work without problem when you map them through the controls config file. If you still having trouble can you place the control templates in a directory different than ~/App_Master fix the controls config, restart the website and see the result.

    Best wishes,
    Radoslav Georgiev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  7. Damir
    Damir avatar
    22 posts
    Registered:
    24 Nov 2008
    23 Oct 2009
    Link to this post
    Ok here is my config for views for events they dont work i tried to restart the server check 10 times the path to template and nothing. I have copied the ListPageMaster.ascx and ListPageDetails.ascx from admin to ControlTemplates/Events folder and even write the test next to the title to see if its working and nothing.

    <viewSettings hostType="Telerik.Events.WebControls.EventsView"
          <additionalTemplates> 
            <!--Item List--> 
            <add key="ItemListTemplatePath" layoutTemplatePath="~/GadgetsTemplates/ControlTemplates/Events/ListPageMaster.ascx" /> 
            <!--Single Item--> 
            <add key="SingleItemTemplatePath" layoutTemplatePath="~/GadgetsTemplates/ControlTemplates/Events/ListPageDetail.ascx" /> 
          </additionalTemplates> 
        </viewSettings> 

    When i try to connect the templates using Advanced tab / Appearance / SingleItemTemplatePath and ItemListTemplatePath then they work.

    So my conclusion is that when binding them in Config that is not working. Did you test this issue
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    23 Oct 2009
    Link to this post
    Hi Damir,

    "There are two possible ways to map an Presentation mode template

    1. Through ControlDesigner
    2. Through SingleItemTemplatePath and ItemListTemplatePath properties of EventsView's Advanced tab.

    You can take a look at the following post for more detailed information - Working with presentation modes.
    "

    I am not sure whether you have checked the article and why you are keep trying to map the template through the configuration file. You cannot map PerentationMode template through ControlsConfig file. As you see there are only two basic ways. So what exactly is not clear in step one or step two and in the blog post, since none of the steps refer to mapping a presentation mode template through ControlsConfig file.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  9. Damir
    Damir avatar
    22 posts
    Registered:
    24 Nov 2008
    23 Oct 2009
    Link to this post
    Thanks for the replay i get it now. Didn't understand the article first time. Thanks for the replay
Register for webinar
9 posts, 0 answered