+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / images & document category bug

images & document category bug

6 posts, 0 answered
  1. Jonathan
    Jonathan avatar
    9 posts
    Registered:
    12 Mar 2009
    29 Sep 2009
    Link to this post
    Hi there,

    I'm using Sitefinity 3.7.2022.3 and I've noticed that it doesn't escape ' single apostrophes when saving categories to the database which results in an error when you try to view the category list whilst a category with the apostrophe is in the database. The manual workaround is to go into the database and remove the apostrophe.

    Jon.
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    29 Sep 2009
    Link to this post
    Hi Jonathan,

    Thank you for reporting this.

    I have tried to reproduce it, but I am not able to. Here are the steps I am taking:

    1. Create a new category in the Images and Documents module (cate'gory)
    2. Upload a picture
    3. Assign it to the category (cate'gory)
    4. View the Image Gallery control in every mode - the picture is shown just fine. 

    Am I missing something? Can you please send us the error message? 

    Thank you in advance!

    Best wishes,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Jonathan
    Jonathan avatar
    9 posts
    Registered:
    12 Mar 2009
    29 Sep 2009
    Link to this post
    Hi Georgi,

    The error occurred for me when I tried to view the list of categories... I'm off to a meeting now but I'll get you a set of steps to reproduce it when I get back.

    Best wishes,
    Jon.
  4. Jonathan
    Jonathan avatar
    9 posts
    Registered:
    12 Mar 2009
    29 Sep 2009
    Link to this post
    In case it helps, the category name I was using is:

    Podcast - Download the 'Back to life, back to normality' podcast to your iPod or portable digital media device



  5. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    29 Sep 2009
    Link to this post
    Hello Jonathan,

    Thank you for the follow up. 
    The problem is now reproducible.  We have updated your Telerik account for reporting the problem.

    Sincerely yours,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. Jonathan
    Jonathan avatar
    9 posts
    Registered:
    12 Mar 2009
    29 Sep 2009
    Link to this post
    Thanks, and you're welcome
Register for webinar
6 posts, 0 answered