+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Invalid Content ID Specified on Blogs

Invalid Content ID Specified on Blogs

5 posts, 0 answered
  1. ColinBowern
    ColinBowern avatar
    20 posts
    Registered:
    12 Aug 2012
    18 Mar 2009
    Link to this post
    When using the blog posts control with a separate single item page the first item in the list works~2c but if I click the second or any other item in the blog list I get taken to the post page and presented with an Invalid Content ID Specified error.~3cbr /~3e ~3cbr /~3e ~5bArgumentException~3a Invalid content ID specified~5d~3cbr /~3e ~26nbsp~3b~26nbsp~3b Telerik.Cms.Engine.WebControls.ContentView.CreateSingleContent~28~29 +2069~3cbr /~3e ~26nbsp~3b~26nbsp~3b Telerik.Cms.Engine.WebControls.ContentView.CreateChildControls~28~29 +5712~3cbr /~3e ~26nbsp~3b~26nbsp~3b Telerik.Blogs.WebControls.BlogPosts.CreateChildControls~28~29 +40~3cbr /~3e ~26nbsp~3b~26nbsp~3b System.Web.UI.Control.EnsureChildControls~28~29 +87~3cbr /~3e ~26nbsp~3b~26nbsp~3b System.Web.UI.Control.PreRenderRecursiveInternal~28~29 +44~3cbr /~3e ~26nbsp~3b~26nbsp~3b System.Web.UI.Control.PreRenderRecursiveInternal~28~29 +171~3cbr /~3e ~26nbsp~3b~26nbsp~3b System.Web.UI.Control.PreRenderRecursiveInternal~28~29 +171~3cbr /~3e ~26nbsp~3b~26nbsp~3b System.Web.UI.Control.PreRenderRecursiveInternal~28~29 +171~3cbr /~3e ~26nbsp~3b~26nbsp~3b System.Web.UI.Control.PreRenderRecursiveInternal~28~29 +171~3cbr /~3e ~26nbsp~3b~26nbsp~3b System.Web.UI.Page.ProcessRequestMain~28Boolean includeStagesBeforeAsyncPoint~2c Boolean includeStagesAfterAsyncPoint~29 +842~3cbr /~3e ~3cbr /~3e ~3cbr /~3e Any thoughts on why that might be~3f~3cbr /~3e
  2. ColinBowern
    ColinBowern avatar
    20 posts
    Registered:
    12 Aug 2012
    18 Mar 2009
    Link to this post
    Looks like Firefox 3.1b3 is mucking up the RadEditor.

    I just went live with the install anyways. Here's an example of the error:

    http://www.colinbowern.com/Post/09-01-17/0x80300001_-_What_do_you_mean_you_don_t_know_what_it_is.aspx
  3. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    20 Mar 2009
    Link to this post
    Hello Colinbo,

    Thank you for providing a live link.
    Could you please try the following:

    1. Login to your web site, and navigate to BlogPost Control -> Edit
    2. Go to the Advance Tab -> Explicit Links
    3. Set  AllowLinksToPrevNextItem to false.

    Let us know about the results.


    Sincerely yours,
    Georgi
    the Telerik team


    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  4. ColinBowern
    ColinBowern avatar
    20 posts
    Registered:
    12 Aug 2012
    20 Mar 2009
    Link to this post
    Hi Georgi,

    That works like a charm - thanks!

    Cheers,
    Colin
  5. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    23 Mar 2009
    Link to this post
    Hello Colin,

    I am glad it worked.
    Don't hesitate to contact us if you have other questions.

    All the best,
    Georgi
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
Register for webinar
5 posts, 0 answered