+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Invalid Postback

Invalid Postback

10 posts, 0 answered
  1. Richard Baugh
    Richard Baugh avatar
    201 posts
    Registered:
    22 Aug 2012
    14 Jun 2007
    Link to this post
    I have gotten this error a couple of times while in the module section. I have been either editing a Generic Content item and click on the "back to all items" linkbutton. If I got back and try it again the error goes away. It doesn't happen all of the time, but I have come across it on a few occasions. It is almost a hit and miss with this one. Event Code below.

    Event Type: Warning
    Event Source: ASP.NET 2.0.50727.0
    Event Category: Web Event
    Event ID: 1309
    Date:  6/13/2007
    Time:  5:05:31 PM
    User:  N/A
    Computer: XXX
    Description:
    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 6/13/2007 5:05:31 PM
    Event time (UTC): 6/13/2007 10:05:31 PM
    Event ID: d9f894a1dd2f4685b84334b55944b5b6
    Event sequence: 27
    Event occurrence: 1
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/2043430726/Root-2-128262448110156250
        Trust level: Full
        Application Virtual Path: /
        Application Path: XXX
        Machine name: XXX 
     
    Process information:
        Process ID: 7564
        Process name: w3wp.exe
        Account name: NT AUTHORITY\NETWORK SERVICE
     
    Exception information:
        Exception type: ArgumentException
        Exception message: Invalid postback or callback argument.  Event validation is enabled using <pages enableEventValidation="true"/> in configuration or <%@ Page EnableEventValidation="true" %> in a page.  For security purposes, this feature verifies that arguments to postback or callback events originate from the server control that originally rendered them.  If the data is valid and expected, use the ClientScriptManager.RegisterForEventValidation method in order to register the postback or callback data for validation.
     
    Request information:
        Request URL: http://domain.com/Sitefinity/Admin/Modules.aspx
        Request path: /Sitefinity/Admin/Modules.aspx
        User host address: XXX
        User: admin
        Is authenticated: True
        Authentication Type: Forms
        Thread account name: NT AUTHORITY\NETWORK SERVICE
     
    Thread information:
        Thread ID: 1
        Thread account name: NT AUTHORITY\NETWORK SERVICE
        Is impersonating: False
        Stack trace:    at System.Web.UI.ClientScriptManager.ValidateEvent(String uniqueId, String argument)
       at System.Web.UI.Control.ValidateEvent(String uniqueID, String eventArgument)
       at System.Web.UI.WebControls.DropDownList.LoadPostData(String postDataKey, NameValueCollection postCollection)
       at System.Web.UI.WebControls.DropDownList.System.Web.UI.IPostBackDataHandler.LoadPostData(String postDataKey, NameValueCollection postCollection)
       at System.Web.UI.Page.ProcessPostData(NameValueCollection postData, Boolean fBeforeLoad)
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
     
     
    Custom event details:

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

  2. Sean
    Sean avatar
    271 posts
    Registered:
    31 May 2006
    15 Jun 2007
    Link to this post
    Hi Richard,

    This is in fact an ASP.Net Issue.

    Please refer to this thread for more information:
    http://www.sitefinity.com/support/forums/support-forum-thread/b1043S-tcddc.aspx

    You either need to wait for the whole page to load before clicking the button, or you need to disable event validation.

    Regards
    Sean
  3. Marlon Walcott
    Marlon Walcott avatar
    13 posts
    Registered:
    31 Oct 2006
    14 May 2008
    Link to this post
    To whom it may concern:

    i have managed to reproduce the error "Invalid postback or callback argument" using the Sitefinity demo. Though this might be an Asp .Net 2.0 issue, it has not been handled properly by Sitefinity.

    These are the steps to reproduce this error:

    1. Create a new page in the root eg. testpage (Page type: Normal Page)
    2. Click create this page button.
    3. Now in the "Select Template" screen, click "Cancel Changes"
    4. Then go to the "Properties"  tab for the newly created page.
    5. Then change the "Page type" from "Normal Page" to "Page Group" (you should see an Error in the Status bar.)
    6. Save the Changes.
    7.   You will now get a 404 Resource cannot be found error. The typically thing to do from here would be to click the browsers back button, so now click the "back" button.
    8. Then go back to the "Properties"  tab for the page that was created ( from 1).
    9. Then change the "Page type" from "Page Group" to "Normal Page" (you should see an Error in the Status bar along with a alert box with the error: "Invalid postback or callback argument".)
    10. Then press "Save Changes" and you will see the page wit hthe error.

    Hope the steps are clear and will allow you to reproduce the error. ( I wanted to upload some screenshots but not seeing where on this to do so). I have also been getting some 404 errors in which some of the pages are not being served from Sitefinity. They only reappear after I restart IIS).

    Everytime I get this following Security Failure:

    Object Open:

    Object Server: SC Manager

    Object Type: SERVICE OBJECT

    Object Name: WinHttpAutoProxySvc

    Handle ID: -

    Operation ID: {0,152379498}

    Process ID: 452

    Image File Name: C:\WINDOWS\system32\services.exe

    Primary User Name: COMPUTERNAME$

    Primary Domain: DOMAINNAME

    Primary Logon ID: (0x0,0x3E7)

    Client User Name: NETWORK SERVICE

    Client Domain: NT AUTHORITY

    Client Logon ID: (0x0,0x3E4)

    Accesses: Query status of service

    Start the service

    Query information from service

    Privileges: -

    Restricted Sid Count: 0

    Access Mask: 0x94

     

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


    I get a corresponding System Error:

    A process serving application pool 'DefaultAppPool' exceeded time limits during shut down. The process id was '2732'.


    and the application errors:

    Exception information:

    Exception type: HttpException

    Exception message: There were errors during services initialization, check the error log for details.

    Request information:

    Request URL: http://mysite.com

    Request path: /

    User host address: 72.27.125.150

    User:

    Is authenticated: False

    Authentication Type:

    Thread account name: NT AUTHORITY\NETWORK SERVICE

    Thread information:

    Thread ID: 19

    Thread account name: NT AUTHORITY\NETWORK SERVICE

    Is impersonating: False

    Stack trace: at Telerik.Framework.ServiceHost.Initialize()

    at Telerik.Cms.Web.CmsHttpModule.Init(HttpApplication context)

    at System.Web.HttpApplication.InitModulesCommon()

    at System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers)

    at System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context)

    at System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context)

    at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)

    Custom event details:

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    and

    ISAPI 'c:\windows\microsoft.net\framework\v2.0.50727\aspnet_isapi.dll' reported itself as unhealthy for the following reason: 'Deadlock detected'.

    Regards,

    Niel

  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    15 May 2008
    Link to this post
    Hello Marlon Walcott,

    Thank you very much for describing the exact steps. We have replicated this behaviour and agree that for the first issue with the template and the page type, Sitefinity should handle such situations.

    We have updated your Telerik account.

    All the best,
    Georgi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. Anton Brown
    Anton Brown avatar
    1 posts
    Registered:
    12 Jan 2007
    13 Jun 2008
    Link to this post
    To Whom it may concern,

    Was a solution found to the Deadlock situation stated above. If so will we need to update our version of Sitefinity.

    Thanks,

    Anton
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    13 Jun 2008
    Link to this post
    Hi Anton Brown,

    This issue is already fixed and you should have no problems with it after installing the hotfix, which we released yesterday.

    All the best,
    Georgi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    13 Jun 2008
    Link to this post
    was this fixed in the hotfix only and not sp2?

    thanks!
  8. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    16 Jun 2008
    Link to this post
    Hi SelArom,

    This issue was fixed for the hotfix. It is not critical, and could occur in very rare cases with earlier versions.

    Sincerely yours,
    Georgi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  9. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    04 Aug 2008
    Link to this post
    does this fix the errors that only occur in the admin? I am getting this problem on my main site, periodically. I'm certain that it's because of the not-fully-loading problem or whatever, but I cannot isolate it because the error message is always generic... will this hotfix work on the front page as well or is there another way to isolate what is causing this error? it only happens on the front page, about a dozen or so times a day...

    if not, do I really have to disable event validation? that seems like an extreme measure!
  10. Yasen
    Yasen avatar
    121 posts
    Registered:
    18 May 2013
    07 Aug 2008
    Link to this post
    Hello SelArom,

    As far as I understand you have a custom menu on your front page which uses Ajax and only on this page you see the error. Could you please try to upgrade this website or at least create a new Sitefinity 3.2 SP2 hotfix project and add this control? This way you could test and see if the problem persists. Also you can make this page external  (.aspx) and see if the problem exists.

    Most probably you won't experience this error with the latest version.

    Greetings,
    Yasen
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Register for webinar
10 posts, 0 answered