+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Problems viewing site in localhost

Problems viewing site in localhost

6 posts, 1 answered
  1. Peter
    Peter avatar
    30 posts
    Registered:
    08 Dec 2010
    21 Jan 2011
    Link to this post
    I'm currently working on a site that uses sitefinity 3.7. After copying the files to my hard-drive using source safe, I tried viewing the page in my localhost when the following error appeared:

    Server Error in '/' Application.

    Could not load file or assembly 'Telerik.Cms.Engine, Version=3.1.3311.24714, Culture=neutral, PublicKeyToken=85fd314cb21bc432' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.IO.FileLoadException: Could not load file or assembly 'Telerik.Cms.Engine, Version=3.1.3311.24714, Culture=neutral, PublicKeyToken=85fd314cb21bc432' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Cms.Engine, Version=3.1.3311.24714, Culture=neutral, PublicKeyToken=85fd314cb21bc432' could not be loaded.

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    

    Stack Trace: 

    [FileLoadException: Could not load file or assembly 'Telerik.Cms.Engine, Version=3.1.3311.24714, Culture=neutral, PublicKeyToken=85fd314cb21bc432' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)]
       System.Reflection.Assembly._GetType(String name, Boolean throwOnError, Boolean ignoreCase) +0
       Telerik.Utilities.TypeResolutionService.GetType(String name, Boolean throwOnError, Boolean ignoreCase) +579
       Telerik.Utilities.StringTypeConverter.ConvertFrom(ITypeDescriptorContext context, CultureInfo culture, Object value) +108
       Telerik.Sitefinity.Configuration.XmlConfigProvider.LoadAttributes(ConfigElement element, XmlReader reader) +321
       Telerik.Sitefinity.Configuration.XmlConfigProvider.LoadElement(ConfigElement element, XmlReader reader, Stack`1 stack) +761
       Telerik.Sitefinity.Configuration.XmlConfigProvider.LoadSection(ConfigSection section) +389
       Telerik.Sitefinity.Configuration.ConfigProvider.GetSection() +279
       Telerik.Sitefinity.Configuration.ConfigManager.GetSection() +104
       Telerik.Framework.Web.ControlUtils..cctor() +64
    
    [TypeInitializationException: The type initializer for 'Telerik.Framework.Web.ControlUtils' threw an exception.]
       Telerik.Framework.Web.ControlUtils.GetTemplate(String virtualPath) +0
       Telerik.Search.WebControls.SearchBox.get_LayoutTemplate() +50
       Telerik.Search.WebControls.SearchBox.CreateChildControls() +90
       System.Web.UI.Control.EnsureChildControls() +146
       System.Web.UI.Control.PreRenderRecursiveInternal() +61
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3394
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.4952; ASP.NET Version:2.0.50727.4955


    Things I've tried:

    * Changing the permissions of the folder (both DefaultAppPool and Network Services)
    * Getting the latest version of the site again. 
    * Checked the web.config and reconfigured connection strings to point to database (probably unrelated)

    Has anyone encountered this problem?

    Thanks!

    Peter
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    21 Jan 2011
    Link to this post
    Hello Peter,

    Please make sure that you have Telerik.Cms.Engine.dll version 3.1.3311.24714 in your bin folder and your project has a reference to it. . The error says that this dll cannot be found in the bin folder and your project does not have a reference to it. If there are custom class libraries in your solution, make sure that they are compiled against the Telerik.Cms.Engine.dll version 3.1.3311.24714 version you have in the bin folder.
     
    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. James@Nw
    James@Nw avatar
    265 posts
    Registered:
    05 May 2009
    21 Jan 2011
    Link to this post
    Hi Ivan,

    Thanks for helping out.

    Peter's copied this entire project from our SourceSafe database which is a duplicate copy of what runs on my machine and which runs with no problems on my machine as well so I am not sure what could be causing this.

    We would like to try the DLL version that's mentioned so could you tell me where I can get that DLL please?

    Thanks,
    James
  4. James@Nw
    James@Nw avatar
    265 posts
    Registered:
    05 May 2009
    24 Jan 2011
    Link to this post
    Hi Ivan,

    Any word on this please?

    Thanks,
    James
  5. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    25 Jan 2011
    Link to this post
    Hi,

    We do not have official version build with this number, so this is a custom build or you have the dll from somewhere else where it was previously attached (blog post , forum post etc). The official versions of 3.1 edition are listed below


    Release Sitefinity 3.1 SP2

        3.1.1473.1 - dev
        3.1.1473.2 - standard
        3.1.1473.3 - community


    Release Sitefinity 3.1 SP1

        3.1.1442.1 - dev
        3.1.1442.2 - standard
        3.1.1442.3 - community

    Release Sitefinity 3.1

        3.1.1412.1 - dev
        3.1.1412.2 - standard
        3.1.1412.3 - community



    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  6. James@Nw
    James@Nw avatar
    265 posts
    Registered:
    05 May 2009
    31 Jan 2011
    Link to this post
    Thanks Ivan.

    This answer option you have built into the forums is dandy, but if you are going down the StackOverflow route, it should be me marking a post as the answer ;)

    Turns out we removed the entire project from SourceSafe and added it again which solved this problem.

    Thanks
Register for webinar
6 posts, 1 answered