+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Recent Upgrade to 3.7 Problems

Recent Upgrade to 3.7 Problems

6 posts, 0 answered
  1. Jackson
    Jackson avatar
    51 posts
    Registered:
    23 May 2008
    29 Mar 2010
    Link to this post
    About half the time when we access our news module.  The grid with all of the news items is empty and after about 30 seconds, this error pops up.

    Stack Trace: /r/nError: The server method 'GetContentItems' failed./r/nStatus Code: 500/r/nException Type: /r/nTimed Out: false

    On previous versions the grid would load fairly quickly.

    Thanks,
    Chris Morrow
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    30 Mar 2010
    Link to this post
    Hi Chris Morrow,

    You could check whether something has blocked the WebService and the WebMethod fails. You could observe the request with FireBug, Fiddler or HttpWatch.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Jackson
    Jackson avatar
    51 posts
    Registered:
    23 May 2008
    21 Apr 2010
    Link to this post
    How would I go about checking if something has blocked the WebService and the WebMethod fails.  

    When I observe the request with HTTPWatch.

    http://www.okc.biz/Sitefinity/Admin/Services/ContentService.asmx/GetContentItems is what is taking all of the time.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    21 Apr 2010
    Link to this post
    Hi Chris Morrow,

    This is the web service that is called when the RadGrid of the module/s is bound. What is the response status? From which version you are upgrading? The Web Service has not been changes since 3.6 version of Sitefinity.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Jackson
    Jackson avatar
    51 posts
    Registered:
    23 May 2008
    21 Apr 2010
    Link to this post
    I upgraded from 3.5.  Sometimes the stories will load, but even if they do it takes over 2 minutes.  I just ran it again and it took 4 minutes to load.  The page loads quickly but the grid is  empty until they load.  And, then about half the time I get that error message.

    + 1.455 238.184 1696 30461 POST 200 application/json; charset=utf-8 http://www.okc.biz/Sitefinity/Admin/Services/ContentService.asmx/GetContentItems
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    22 Apr 2010
    Link to this post
    Hi Chris Morrow,

    The binding of the Grid is made by WebService - Client Side binding which means that this should be several times faster that version 3.5. Could you try to upload the project on anther server and see whether the problem will persist? Could you run the  project by using VS WebServer? If the project runs fine when through VS web server then the problem comes from the IIS server.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Register for webinar
6 posts, 0 answered