+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Removed Tag Parameter from Image Object

Removed Tag Parameter from Image Object

5 posts, 0 answered
  1. Anne Wade
    Anne Wade avatar
    3 posts
    Registered:
    04 Feb 2010
    28 May 2010
    Link to this post

    Hello,

    In order to add parameters to an image at the time it is selected from the image selector popup windows, we have implemented OnClientPasteHtml running the code associated to that event only for "MediaManager" command.

    We get the image selected implementing the get_value method (args.get_value();) and then work with the captured string to add some parameters, in this case: (<param name="windowlessVideo" value="true">). After adding this parameter the args content is updated set_value(updated string);

    This method seems to work, meaning that the image has the expected behaviuor after inserting it in the Placeholder. The issue arises when we change to the HTML view: at that time, we see that the HTML resulting doesn't have the parameter added (windowlessVideo), going back to the "Design" view the behaviour of the image is not the expected: it overlaps the image selector popup window, something that doesn't happen while we don't change from Design view to HTML view.

    Changes are applied, but the param tags are removed when we change the view. Has anyone experienced this issue before? Is there a workaround?

     

    Thank you very much

  2. Stanimir
    Stanimir avatar
    2 posts
    Registered:
    30 Nov 2016
    28 May 2010
    Link to this post
    Hi Anne Wade,

    Could you confirm which version of RadEditor for MOSS you are using? I was not able to reproduce this behavior in our online demos http://demos.telerik.com/aspnet-ajax/editor/examples/default/defaultcs.aspx or in MOSS by using RadEidtor for MOSS 5.3.7.

    Kind regards,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Anne Wade
    Anne Wade avatar
    3 posts
    Registered:
    04 Feb 2010
    02 Jun 2010
    Link to this post
    Hi Stanimir,

    The version I have in my environment is 5.6.2.0. See attached file to check RadEditorSharePoint.dll version.

    Best Regards.
  4. Stanimir
    Stanimir avatar
    2 posts
    Registered:
    30 Nov 2016
    02 Jun 2010
    Link to this post
    Hi Anne,

    Before setting the value with the args.set_value(html) method you need to make sure that you modify the content with the IEKeepObjectParamsFilter and MozillaKeepFlashString content filters of the editor.

    Here is a sample of javascript code which you need to execute before args.set_value(html):
    var filterIE = editor._filtersManager.getFilterByName("IEKeepObjectParamsFilter");
    var filterMozz = editor._filtersManager.getFilterByName("MozillaKeepFlashString");
    html = (filterIE) ? filterIE.getDesignContent(html) : html;
    html = (filterMozz) ? filterMozz.getDesignContent(html) : html;
     
    args.set_value(html);


    I hope this helps.

    Sincerely yours,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Anne Wade
    Anne Wade avatar
    3 posts
    Registered:
    04 Feb 2010
    03 Jun 2010
    Link to this post
    Hi Stanimir,

    The code you provided works: the param tags from objects are not removed.

    Thank you very much for your help!!

    Best Regards.
Register for webinar
5 posts, 0 answered