+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Sitefinity gives "Invalid content id" when editing shared content

Sitefinity gives "Invalid content id" when editing shared content

2 posts, 0 answered
  1. Abel Braaksma
    Abel Braaksma avatar
    20 posts
    Registered:
    15 Jul 2009
    18 Apr 2010
    Link to this post

    When you edit a Template and hit an item that's shared content, the CMS gives a link to edit the shared content right from that spot, without first going to Modules. However, when you click "Save", the edit-section blanks and a text is shown "Invalid content Id". Sometimes the error is not shown, but then the content isn't saved either.

    A workaround is easy: go to Modules and select Content Items and edit the shared content items from that spot. But that doesn't make the bug (is it?) less annoying... 

    Any help of what I am doing wrong or what I am misunderstanding about the CMS is greatly appreciated.

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    18 Apr 2010
    Link to this post
    Hi Abel Braaksma,

    If you open thetemplate/ page and delete the control(GenericContent), then drag and drop it on this template/page and try to modify the content does the problem persist? The way that I am able to reproduce this issue is only when the content item is deleted from the module and there is reference to it in the GenericContent control.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
2 posts, 0 answered