+1-888-365-2779
Try Now
More in this section

Forums / Deployment / 500.21 Error for PUT web service calls in Admin

500.21 Error for PUT web service calls in Admin

2 posts, 0 answered
  1. LBrinley
    LBrinley avatar
    59 posts
    Registered:
    29 Dec 2005
    13 Jun 2012
    Link to this post
    We just moved our website from its dev subdomain to the "live" url on the same Windows 2008 R2 64-bit server with IIS 7.5. Although the public portions of the site function as expected, we now receive the following error message whenever we PUT to a web service in the Sitefinity admin--essentially any attempt to use the admin to update a page, content item, rss or search index, etc. Needless to say, these issues did NOT occur on the dev subdomain on this same server.

    ERROR 500.21
    Handler "svc-Integrated-4.0" has a bad module "ManagedPipelineHandler" in its module list

    Having Googled the 500.21 and the above message, I have already used aspnet_regiis -i to rebuild ASP.NET 4.0.30319 and "repaired" ASP.NET 4 on this server without success. I've also added a machine key to the web.config without success. I've also checked and rechecked IIS settings, permissions, etc.

    Since this site's admin worked fine on the dev subdomain, I'm at a loss.  Any suggestions?

    UPDATE: For those interested, the solution to this issue was to simply create a new web site within IIS 7.5 on this server. Although the settings, files, etc. for the new site are identical to the original--we copied them--the new site works without issue.  I suppose this is the "clean" installation path that has appeared on many other threads.  Don't know why it was necessary, but it works.
  2. THNTEC
    THNTEC avatar
    1 posts
    Registered:
    04 Nov 2010
    07 Aug 2012
    Link to this post

    Your <handler> section is probably invalid.

    HTTP Error 500.21 - Internal Server Error

    Handler "<HANDLER_NAME>" has a bad module "ManagedPipelineHandler" in its module list

    You probably have a handler mapping that does not have the correct precondition.  

    IIS is not forgiving in regard to typos, and preconditions are case-sensitive.  

    The text must be preCondition=”integratedMode” or preCondition=”classicMode”.

    1) Check this post for more information: 

    http://blogs.msdn.com/b/tmarq/archive/2007/08/30/iis-7-0-asp-net-pipelines-modules-handlers-and-preconditions.aspx

    2) Also, set the preCondition mode of your IsapiModule:

    <add name="WildCard" path="*" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" requireAccess="None" preCondition="classicMode,runtimeVersionv4.0,bitness64" />

    <add name="WildCard32" path="*" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" requireAccess="None" preCondition="classicMode,runtimeVersionv4.0,bitness32" />  


2 posts, 0 answered