+1-888-365-2779
Try Now
More in this section

Forums / Deployment / IIS 7 and .NET 4 svc handler issue

IIS 7 and .NET 4 svc handler issue

4 posts, 0 answered
  1. michael
    michael avatar
    4 posts
    Registered:
    01 Jun 2011
    02 Jun 2011
    Link to this post
    Hi All

    Ran into an interesting problem that I could not find any doc's for.

    This specifically related deploying Sitefinity 4.1.1395.0 to an IIS 7.5 server (Windows 2008 SP1). The issue was I would get 404 - Folder or File not found when i logged into the administration console and tried to access almost any function. The problem was specifically to do with handling of *.svc files. In the docs, it states that you need to add a http handler into the site for *.svc pointing to %windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll. This did not work and the error persisted. What I found was if I changed the application pool to run in classic mode, it worked, but integrated mode it would not. So, my resolution I found was:

    instead of adding a script manager handler in pointing to a file, I added a managed handler instead with:
    Request Path: *.svc
    Type: System.ServiceModel.Activation.ServiceHttpHandlerFactory, System.ServiceModel.Activation, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
    Name: svc-Integrated-4.0

    This seemed to resolve my issue. Just thought I would share as an option if anyone else has the same issue.
  2. Max
    Max avatar
    1 posts
    Registered:
    22 Sep 2011
    29 Oct 2011
    Link to this post
    Hi Michael,

    Just wanted to thanks for sharing. Exactly the same problem and your solution does work fine.

    Telerik guys could update their manuals I guess.


    Cheers,
    Max.
  3. Sheena
    Sheena avatar
    11 posts
    Registered:
    24 Sep 2012
    24 Sep 2012
    Link to this post
    Hi,

    Thanks also for sharing this.


  4. Sheena
    Sheena avatar
    11 posts
    Registered:
    24 Sep 2012
    24 Sep 2012
    Link to this post
    Hi,

    Thanks also for sharing this.


4 posts, 0 answered