+1-888-365-2779
Try Now
More in this section

Forums / Deployment / js from Telerik.Web.UI.WebResource.axd fails to load (net::ERR_CONTENT_LENGTH_MISMATCH)

js from Telerik.Web.UI.WebResource.axd fails to load (net::ERR_CONTENT_LENGTH_MISMATCH)

4 posts, 1 answered
  1. Tobias
    Tobias avatar
    6 posts
    Registered:
    04 Feb 2009
    05 Jan
    Link to this post

    Occurs with one script on the Content editing page in Sitefinity's backend, otherwise all seems to work normally. The script only loads to about it's half, and then ends abruptly. The script's length varies by some +/-10 bytes each time I reload.

    This happens only when I access Sitefinity's backend from a remote client, locally all is fine, on the server as well as on my development machine.  No problems with scripts of similar size on the same page, so this is propably not an issue with server limitations. Server is a Windows Server 2012 R2.

    No traces show in Sitefinity's error logs, nor the windows logs.

    Did anyone run in this type of issue? Any ideas/suggestions appreciated!

  2. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    08 Dec 2016
    07 Jan
    Link to this post
    Hi Tobias,

    On which content editing page the issue is reproduced? Is it possible to open the same page from the remote client and from the development machine and check what is the script that is failing or at least narrow down which script are loading correctly on the page?
    You can also try disabling the script combining from Advanced settings -> Pages, Combine backend script resources - set it to False.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Tobias
    Tobias avatar
    6 posts
    Registered:
    04 Feb 2009
    18 Jan in reply to Nikola Zagorchev
    Link to this post

    We've been finally able to track the issue down to a bug in our web hoster's content filtering system, which simply blocked the script from beeing submitted for no apearent reason. Thank you for your efforts!

    Best regards

    Tobias

    Answered
  4. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    08 Dec 2016
    18 Jan
    Link to this post
    Hello Tobias,

    Thank you for letting us know. We are glad the issue is resolved.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
4 posts, 1 answered