+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Publishing on dev is messing up live website

Publishing on dev is messing up live website

2 posts, 0 answered
  1. Lourdu
    Lourdu avatar
    7 posts
    Registered:
    06 Sep 2012
    05 Oct 2012
    Link to this post
    Hi,

    I am adding content to a page(not home page) on dev server and publishing it but cant see the published content instead it is messing up the home page of the website that is live. All the three environments dev, stag and production are on separate servers and databases. Did anybody face similar issue or anyone has any suggestions please advice.
  2. Patrick Dunn
    Patrick Dunn avatar
    237 posts
    Registered:
    03 Nov 2014
    07 Oct 2012
    Link to this post
    Hi,

     Thank you for contacting Sitefinity support. Please make sure that you have an unaltered connection string on your dev and live servers. You can check these under ~/App_Data/Sitefinity/Configuration/DataConfig.xml

    Using SQL Express you might see something like this:

    <connectionStrings>
     
        <add connectionString="Data Source=.\SQLEXPRESS;Integrated Security=True;User Instance=True;AttachDBFilename=|DataDirectory|Sitefinity.mdf" providerName="System.Data.SqlClient" dbType="MsSql" name="Sitefinity" />
     
      </connectionStrings>

    If you are using a SQL install database check the connection string and initial catalog. Please also check and confirm that there are no connection strings in your web.config that would be set to the wrong server. All the best,
    Patrick Dunn
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered