+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Updating 4.2.1733 to 5.0.2860.0

Updating 4.2.1733 to 5.0.2860.0

15 posts, 1 answered
  1. WebGuy
    WebGuy avatar
    16 posts
    Registered:
    24 Jun 2011
    16 May 2012
    Link to this post
    I have an old sitefinity setup that is still on version 4.2.1733.  I see you can do an update straight into 5.x from 4.3 or 4.4 and 3.7 but not from 4.0-4.2.  I can't find any of these older Sitefinity Program Managers in my software downloads so i can take my 4.2 to 4.4 and then upgrade to 5.  I tried running 5.0.2860.0 and upgrading the old site but it creates an error saying:

    The database schema version (2800) is higher then the running Sitefinity version (1733).  Downgrade is not allowed.

    Any suggestions?
  2. Waseem
    Waseem avatar
    24 posts
    Registered:
    31 Jul 2012
    17 May 2012
    Link to this post
    Hi WebGuy,
    I have corrected myself about sitefinity version numbers in my next reply, while my instance on your error is the same as i mentioned earlier that it looks like DB error so you better consider the version of your db you are updating to and from.
    Regards.
  3. Waseem
    Waseem avatar
    24 posts
    Registered:
    31 Jul 2012
    18 May 2012
    Link to this post
    Hi WebGuy,
    First of all let me appologise and correct myself on my point that any of the sitefinity 4.x version can be upgraded to 5.x. Sitefinity only support an upgrade from last 2 versions and those are 4.3 and 4.4 so by going stiefinity upgradation track, 4.1 version should be upgraded to 4.3 and than from this point it can be upgraded to 5.0. I am also going to upgrade a 4.1 site to 5.0 and obviously have to move on to 4.3 first and than from that point will take it to 5.0.
    Let me know if you have any luck with your problem?
    Regards
  4. WebGuy
    WebGuy avatar
    16 posts
    Registered:
    24 Jun 2011
    18 May 2012
    Link to this post
    Yes, that's what i was saying.  I need to know where i can find a project manager of 4.3 or 4.4 so i can run that update first and then finish into 5.  Where do you find these older Sitefinity Project Managers at?
  5. Waseem
    Waseem avatar
    24 posts
    Registered:
    31 Jul 2012
    18 May 2012
    Link to this post
    I assume you or your company has a sitefinity account so if you go to the Sitefinity download and other resources, you will find the previous versions of Sitefinity Project Manager.
    P.S. I am upgrading from 4.1(SP2) to 4.2 and getting Telerik.Openaccess.Runtime error. Tried everthing but it looks like as my upgraded project still referencing to the older version of Open Access. Any idea about how to resolve this problem?
    Regards
    Answered
  6. WebGuy
    WebGuy avatar
    16 posts
    Registered:
    24 Jun 2011
    18 May 2012
    Link to this post
    Sadly I haven't messed with the OpenAccess yet so I couldn't even guess at to what it might be.

    Thanks for pointing the older version area out.  The link was sitting there in plain sight yet I couldn't find it.  I attached a screen shot in case anyone in the future comes across this thread.  I did update the project to 4.4 and then to 5.0.  I'm getting a new error which i'll have to hunt down and fix on the SQL Express side it looks like:

    Cannot open user default database. Login failed.
    Login failed for user 'NT AUTHORITY\NETWORK SERVICE'.

    Which can be fixed by:
    1- Login to SqlExpress via SQL Server Management Studio
    2- Go to the "Security" directory of the database
    3- Right-click the Users directory
    4- Select "New User..."
    5- Add 'NT AUTHORITY\NETWORK SERVICE' as a new user
    6- In the Data Role Membership area, select db_owner (see Settings.gif)
    7- Click OK
  7. WebGuy
    WebGuy avatar
    16 posts
    Registered:
    24 Jun 2011
    18 May 2012
    Link to this post
    Waseem,

    What is the error message you are getting?  This might be what your looking for:

    "Could not load file or assembly 'Telerik.OpenAccess..."
    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/could-not-load-file-or-assembly-telerik-openaccess-version-2011-1-510-1.aspx 
  8. Waseem
    Waseem avatar
    24 posts
    Registered:
    31 Jul 2012
    21 May 2012
    Link to this post
    Hi WebGuy,
    you can try ammending your connectionstring in App_Data->Sitefinity->Configuration->DataConfig.config file. Just look at this location what's your connection string reffering to. Otherwise, just comment the current connection string and than add a new one with the DB settings of the system where your sitefinity DB resides.
    P.S. thanks for the reply to my Open Access issue. I have the same error as of the link you supplied in your reply. I am already been through all the posts on sitefinity forum regarding to this issue but still no luck. Thanks once again.
    Regards!
  9. WebGuy
    WebGuy avatar
    16 posts
    Registered:
    24 Jun 2011
    21 May 2012
    Link to this post
    Thanks for the help.  I'm knocking out these errors one by one and now am on the same error you may be seeing:

    Could not load file or assembly 'Telerik.OpenAccess, Version=2011.2.713.3, Culture=neutral, PublicKeyToken=7ce17eeaf1d59342' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    I think this means the dll's version number doesn't match the project version number.  I'll let you know what i find.
  10. Waseem
    Waseem avatar
    24 posts
    Registered:
    31 Jul 2012
    21 May 2012
    Link to this post
    You are welcome :)
    I am on this error since friday and doesn't look like that easy to be get rid off.
    I'll advise you to look at all of your reference carefully and update them accordingly in all of your reference folders. I am currently stuck with Telerik.OpenAccess.SDK and funny thing is, I dont have an access to the 4.2.1733 SDK libraries and currently trying to get hold on to that particular SDK version.
    By the way is there any chance if you can look into you project and see if you may have Telerik.OpenAccess.SDK libraries for Sitefinity 4.2.1733.0.
    Wish you good luck and let me know when you fix it.
    Regards!
  11. WebGuy
    WebGuy avatar
    16 posts
    Registered:
    24 Jun 2011
    21 May 2012
    Link to this post
    I ended up doing two things which got me by this error.

    1- make a backup of your project.
    2- take the Telerik.OpenAccess dll files from the "_EmptyProject" folder (see image #1).  Copy those and replace the ones you have in your current project (see image #2)  Restart IIS or Project Manager and see.
    3- If still not working, replace all dll files and not only the OpenAccess ones. Restart again.
    4- If still not working, open the web.config file in your project and add this to the bottom (see image #3), but change this to match your version numbers shown in the error message:

    <runtime>
            <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
                <dependentAssembly>
                    <assemblyIdentity name="Telerik.OpenAccess" publicKeyToken="7ce17eeaf1d59342"/>
                    <bindingRedirect oldVersion="2011.2.713.3" newVersion="2011.3.1320.1"/>
                </dependentAssembly>
            </assemblyBinding>
        </runtime>

  12. Waseem
    Waseem avatar
    24 posts
    Registered:
    31 Jul 2012
    23 May 2012
    Link to this post
    @WebGuy,
    I have successfuly upgraded to 4.2.1733.0. Though it was a nerve-wracking process but at the end, it was really a good learning. My project has 9 additional modules and their build was not getting updated in my WebApp\bin directory. On Build Solution, everything was bang on but it was throwing exceptions at run time. Most common exceptions were of Telerik.Sitefinity, Telerik.OpenAccess and Telerik.OpenAccess.Runtime can't find the older version .DLL's. By chaning the output path of all the modules to the WebApp\Bin directory solved my problem.
    Now have to move on to the next phase i-e. 4.3.
    Regards!
  13. WebGuy
    WebGuy avatar
    16 posts
    Registered:
    24 Jun 2011
    23 May 2012
    Link to this post
    Glad you are getting it working.  Yes, you could update to either 4.3 or 4.4 and then do the final upgrade to 5 like i did.  The main different between us is that I didn't have any custom modules... yet.  

    Perhaps one day this update (and module registration) will all be done through the admin page much like WordPress and other CMS solutions.  Sitefinity still requires a lot of manual tweaking to get it happy.
  14. Waseem
    Waseem avatar
    24 posts
    Registered:
    31 Jul 2012
    23 May 2012
    Link to this post
    Thanks for all of your help!
  15. Anthony
    Anthony avatar
    17 posts
    Registered:
    23 Jun 2011
    27 Nov 2014
    Link to this post

    just change the assembly version number in web.config to be

      <add assembly="Telerik.OpenAccess, Version=2013.1.418.2, Culture=neutral, PublicKeyToken=7ce17eeaf1d59342"/>

15 posts, 1 answered