Try Now
More in this section

Forums / Deployment / Directory listing denied

Directory listing denied

5 posts, 0 answered
  1. jimmy
    jimmy avatar
    5 posts
    21 Mar 2008
    29 Apr 2008
    Link to this post
    I have sitefinity set up, but when I go to the root folder it displays the following error:


    Directory Listing Denied

    This Virtual Directory does not allow contents to be listed.

    If I type in /Default.aspx it works fine, it's just when I go to the root.  I have already gone to the websites properties, documents tab, and checked the 'Enable default content page' checkbox and made sure that Default.aspx is at the top of the list, but it still doesn't work...
  2. Georgi
    Georgi avatar
    3583 posts
    10 Oct 2016
    30 Apr 2008
    Link to this post
    Hello jimmy,

    We couldn't find any reason for this error message to be displayed. It seems you have already set Default.aspx to be a default document in your IIS.

    What version of IIS are you using ?

    Sincerely yours,
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Jason M
    Jason M avatar
    108 posts
    15 Jan 2007
    09 May 2008
    Link to this post
    I also noticed this issue.

    On your demo site I added the ~/AboutUs/Default.aspx alias to the ~/AboutUs/AboutTIU.aspx page so that the following urls both resolve properly:

    However, when I type the following url in my browser I get the 404 message Jimmy received.
  4. Rebecca
    Rebecca avatar
    536 posts
    24 Sep 2012
    10 May 2008
    Link to this post
    Hello Jason M,
    We think Jimmy got another error. The Directory Listing Denied error means that Internet Information Services can't find a default document to open. This is probably due to the fact that he doesn't have Default.aspx in the list with default documents. Here are the steps to add it:
    1. Open IIS and and from your project virtual directory properties, click the Documents tab.
    2. Make sure the checkbox "Enable default document" is checked. If Default.aspx is not in the list with default documents, click Add and type Default.aspx in the Textbox.

    The behavior you describe is normal, as our demo site is not configured to handle extensionless URLs.
    Please follow the instructions in our User Manual if you want to create pages without file extensions in your site. You can do that by setting wildcard application mappings in IIS or by configuring 404 redirection. For details about each approach, please refer to section Wildcard Application Mappings and Extensionless URLs.

    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. Joe
    Joe avatar
    2 posts
    27 Jun 2007
    03 Jun 2008
    Link to this post
    It's because you've physically deleted the Default.aspx file that came in the root with the new site instance.  I had the same thing happen to me.  Just create a new blank file called Default.aspx
Register for webinar
5 posts, 0 answered