+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Browser compatability

Browser compatability

2 posts, 0 answered
  1. Tom Holder
    Tom Holder avatar
    7 posts
    Registered:
    09 Feb 2004
    30 Mar 2005
    Link to this post
    What part of sitefinity adds the IE 5.5+ requirement for administration? It seems strange as all of the telerik controls work commendably well with most browsers.

    Thanks, looking forward to getting under the hood of this bad boy.
    Tom
  2. Chris
    Chris avatar
    8 posts
    Registered:
    20 Aug 2015
    31 Mar 2005
    Link to this post
    Hi Tom,

    The requirement for IE 5.5+ in Sitefinity comes from the designer control as its JavaScript and dialogs work only on this browser. That said, we are already working on the next version of Sitefinity which will support also Mozilla, Netscape and Firefox. 

    Don't hesitate to contact us if you have other questions.

    Kind Regards,
    the telerik team
2 posts, 0 answered