1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / DLL version problem between SiteFinity and OpenAccess

DLL version problem between SiteFinity and OpenAccess

4 posts, 0 answered
  1. Tevez
    Tevez avatar
    8 posts
    Registered:
    01 Aug 2011
    03 Aug 2011
    Link to this post
    I'm having problems with using an OpenAccess based project in a SiteFinity website. As i don't which forum is the best for this type of 2 product question, i thought i'd add a link to the question on the OpenAccess forum as well:
    http://www.telerik.com/community/forums/orm/general-discussions/conflict-with-sitefinity-and-oa.aspx

    I'm really in need of some help for this one, because right now it seems like our OA product won't work with SiteFinity, which in the beginning seemed such a nice combination..

    Best regards, Tevez
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    03 Aug 2011
    Link to this post
    Hi Tevez,

    Why don't you compile your project with a reference from the OpenAccess version that is shipped with Sitefinity? This would not cause issues related to the assembly version.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Tevez
    Tevez avatar
    8 posts
    Registered:
    01 Aug 2011
    03 Aug 2011
    Link to this post
    Hi Ivan,
    I tried to remove the newer references from my project. And then i added the references again, to the Telerik.OpenAccess.dll and Telerik.OpenAccess.35.Extensions.dll that we're shipped with SiteFinity.
    On my development machine where both SiteFinity and the latest version of the OpenAccess ORM are installed, i cannot build my project. Although references have been replaced, when building i get an error that says: that the older version (2011.1.510.1) was found, but the newer version (2011.2.713.3) was expected!
    Is this because that is the OA version that is installed on that computer (including the integration with Visual Studio)?

    When i move the whole project to a computer that has nothing but Visual Studio installed, copy the .dll's from the SiteFinity project and reference them in my copied project, then my project build just fine..

    Is there a way i don't have to move my custom project to a separate machine? I'd really like to work on both projects, on one development machine.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    04 Aug 2011
    Link to this post
    Hello Tevez,

    I haven't encounter the issue locally. The reference get set correctly. It might be something that OA requires, so let's see what the OA support team will tell you about this issue.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered