1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Mootools Widget does not work with sitefinity widgets

Mootools Widget does not work with sitefinity widgets

8 posts, 1 answered
  1. xor
    xor avatar
    42 posts
    Registered:
    04 Jan 2010
    09 Jan 2012
    Link to this post
    I am using a slideshow control that is based on Mootools javascript libray for my custom news widget. When I add any sitefinity build in widget on the page, my control doesn't load.

    Any idea?

    Thanks in advance,
    Fadi Raheel
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    09 Jan 2012
    Link to this post
    Open up firebug in firefox (console tab)

    What is it telling you? (any script errors?)
  3. xor
    xor avatar
    42 posts
    Registered:
    04 Jan 2010
    09 Jan 2012
    Link to this post
    Getting the error:
    _lofmain.getElement is not a function
  4. xor
    xor avatar
    42 posts
    Registered:
    04 Jan 2010
    11 Jan 2012
    Link to this post
    I uploaded the Widget files here.
    Attached is a screenshot before and after adding news widget.





  5. xor
    xor avatar
    42 posts
    Registered:
    04 Jan 2010
    12 Jan 2012
    Link to this post
    Hi All,

    I am stuck on this and would appreciate any help.
    Thanks in advance.

    Fadi Raheel


    EDIT: Fixed
  6. Svetoslav Petsov
    Svetoslav Petsov avatar
    456 posts
    Registered:
    24 Sep 2012
    17 Jan 2012
    Link to this post
    Hi,

     Did you add your control to a Widget template or to the page directly? From the picture, I suppose you added it to the News Widget's template (or another widget) and probably there is some missing references in the template. If this is correct, can you send me the widget template, so I can inspect exactly how you added your control?

    All the best,
    Svetoslav Petsov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. xor
    xor avatar
    42 posts
    Registered:
    04 Jan 2010
    17 Jan 2012
    Link to this post
    Thanks Svetoslav for your reply.

    I registered it as:
    <add enabled="True" title="Custom" name="Custom">
        <tools>
            <add enabled="True" type="~/Custom/FeaturedNews/FeaturedNewsWidget.ascx" title="FeaturedNews" description="Featured News Widget" visibilityMode="None" name="FeaturedNews" />
        </tools>
    </add>

    Anyways, i got it resolved by adding  jQuery.noConflict();  before the code that references the Mootools. 

  8. Svetoslav Petsov
    Svetoslav Petsov avatar
    456 posts
    Registered:
    24 Sep 2012
    18 Jan 2012
    Link to this post
    Hello,

    I'm glad that you fixed your issue.
     That was going to be my second suggestion - that there is a jquery conflict with the version of the library that Sitefinity loads and the one from your control. You can check the version that Sitefinity loads from the Backend administration and settings page and load the same in your control, so no conflicts are caused. The other way around this is what you did - calling the noConflct() method. 

    All the best,
    Svetoslav Petsov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
8 posts, 1 answered