+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / New field not appearing in “Sitefinity Dynamic items Field Control Selector” in edit mode

New field not appearing in “Sitefinity Dynamic items Field Control Selector” in edit mode

2 posts, 1 answered
  1. kamii47
    kamii47 avatar
    71 posts
    Registered:
    02 Mar 2007
    26 Jun 2014
    Link to this post
    I am using sitefinity 6.3. I have a have created Sitefinity Dynamic items Field Control Selector for one of my field which contains text,date, image and choices.\

    Initially it generated just Title and Publication Field to appear in the grid when i select this dynamic module items.

        <sf:FlatSelector ID="itemsSelector" runat="server" ItemType="Telerik.Sitefinity.GenericContent.Model.Content"
                DataKeyNames="Id" ShowSelectedFilter="false" AllowPaging="false" PageSize="10" AllowMultipleSelection="true"
                AllowSearching="true" ShowProvidersList="false" InclueAllProvidersOption="true"
                SearchBoxTitleText="Filter by Title" ShowHeader="true"
        ServiceUrl="~/Sitefinity/Services/DynamicModules/Data.svc/live/">
                <DataMembers>
                    <sf:DataMemberInfo runat="server" Name="Title" HeaderText='Title'>
                        <strong>{{Title.Value}}</strong>
                    </sf:DataMemberInfo>
                    <sf:DataMemberInfo runat="server" Name="PublicationDate" HeaderText='Date'>
                        <span>{{PublicationDate ? PublicationDate.sitefinityLocaleFormat('dd MMM, yyyy') : ""}}</span>
                    </sf:DataMemberInfo>
                </DataMembers>
            </sf:FlatSelector>

    Later I added two new fields in it

        <sf:DataMemberInfo  runat="server" Name="SpeakerCategory" HeaderText='Speaker Category'>
                         {{SpeakerCategory.Text}}
                    </sf:DataMemberInfo>
        <sf:DataMemberInfo runat="server" Name="Photo" HeaderText='Photo'  IsExtendedSearchField="true">
                         <img sys:src="{{Photo[0].ChildItemAdditionalInfo}}" width="80" height="80"  />
                    </sf:DataMemberInfo> 

    And able to view when i am adding the items. But in edit mode i am not able to see new fiels.
    any Idea what's wron i am doing
  2. kamii47
    kamii47 avatar
    71 posts
    Registered:
    02 Mar 2007
    26 Jun 2014 in reply to kamii47
    Link to this post

    It ended up a caching issue while i remember i have atleast tried it a dozen time. 

    Answered
2 posts, 1 answered