+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Throwing Server Error while entering Dots(..) at end of url . How to Resolve this trailing issue

Throwing Server Error while entering Dots(..) at end of url . How to Resolve this trailing issue

7 posts, 0 answered
  1. DivyaSagar
    DivyaSagar avatar
    3 posts
    Registered:
    28 Apr 2015
    28 Apr 2015
    Link to this post

    i was trying to enter dots at end of the url of every particular page , but throwing a run time error as shown below.

    Runtime ErrorDescription: An exception occurred while processing your request. Additionally, another exception occurred while executing the custom error page for the first exception. The request has been terminated. 

     Even the sitefinity page is also throwing the page error.

    Can any one suggest how to over come this issue or where can i find this code ?

    Please Check the attached Screen Shot .

  2. Junior Dominguez
    Junior Dominguez avatar
    115 posts
    Registered:
    06 Dec 2016
    01 May 2015
    Link to this post
    Hi DivyaSagar,

    Is there a specific reason for you to do that? Please note that not only Sitefinity, but most of the web servers will react the same way since they will assume there is another domain level.

    Best Regards,
    Junior Dominguez
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. DivyaSagar
    DivyaSagar avatar
    3 posts
    Registered:
    28 Apr 2015
    01 May 2015 in reply to Junior Dominguez
    Link to this post

    Hi Dominguez ,

     Yes,  i do have a requirement to withstand in same page without throwing errors after entering dots at end of url . Can you please let me know how to resolve this ? or is there any upcoming feature in sitefinity or any suggestions so that i can implement in my project .

    Thanks,

    Sagar

  4. ch
    ch avatar
    25 posts
    Registered:
    14 May 2014
    01 May 2015
    Link to this post

    I don't know if this will help because I really don't know what you are trying to achieve. However, you can add a question mark and then enter the period(s) and you will not get an error:

    http://www.sitefinity.com/customers/overview?.​

  5. ch
    ch avatar
    25 posts
    Registered:
    14 May 2014
    01 May 2015
    Link to this post

    Slash dot also works

    http://www.sitefinity.com/customers/overview/.​

  6. DivyaSagar
    DivyaSagar avatar
    3 posts
    Registered:
    28 Apr 2015
    01 May 2015
    Link to this post

    can you let me know how this is implemented ..

     Thanks,

    Sagar

  7. ch
    ch avatar
    25 posts
    Registered:
    14 May 2014
    01 May 2015
    Link to this post

    Not sure what your asking. All I did was type the url into the browser. Upon further thought this is how I would attempt to achieve what you are asking:

    It "might" be possible to force Sitefinity to automatically add a slash or ? at the end of the URL. Google sitefinity url rewriting. This way it would be just like you asked. The user would enter just a period at the end of the url in the browser.

    Another thing. Having the URL end in a slash is cleaner than ending in a question mark. However, you can not add a bunch of periods after a slash. So if your using multiple periods than you will have to end the url in a question mark.

     

7 posts, 0 answered