1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

4 posts, 0 answered
  1. Rakesh
    Rakesh avatar
    17 posts
    Registered:
    24 Feb 2012
    29 Feb 2012
    Link to this post
    hi,

    While developing when I get the error as 
    Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

    I just copy the fresh dll files from _EmptyProject and replace them with my existing dlls and build the solution and the error gets resolved and every thing works fine but after hosting my project I get the same error what I do than is replace the SitefinityWebApp again which works fine for a while but again I am started getting the same error.

    So can someone have a proper solution to the problem

    Thanks & Regards
    Rakesh
  2. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    29 Feb 2012
    Link to this post
    Rakesh, I can usually avoid getting this error while developing by selecting "Build" instead of "Rebuild" for my project. However, you say you are getting this after deploying the site to your live hosting? Have you built the project as Release before deploying? Are you using any external libraries or class library projects in your site?
  3. Bilal Haider
    Bilal Haider avatar
    3 posts
    Registered:
    08 Aug 2012
    02 Sep 2012
    Link to this post
    i downloaded a sample from support forum which was made for the previous version than i am having.

    I tried the recommended solution  (in the visual studio menu bar)
    telerik -> [ product name ] -> Update References

    it recovered the missing DLLs but the build was giving this error and no DLL name was mentioned.

    Clean and Rebuild was also not helpful. I manually cleared the bin and obj folders of the solution and then re-building the solution solved the issue
  4. Bilal Haider
    Bilal Haider avatar
    3 posts
    Registered:
    08 Aug 2012
    03 Sep 2012
    Link to this post
    [duplicate text removed]
4 posts, 0 answered