Try Now
More in this section

Forums / Developing with Sitefinity / 2 libraries manager

2 libraries manager

2 posts, 0 answered
  1. Olivier
    Olivier avatar
    57 posts
    09 Jul 2010
    29 Oct 2010
    Link to this post

    For our website, since we have a lot of libraries, we created a second libraries provider which is extending Telerik.Libraries.Data.DefaultProvider, to hide a certain type of library. We only overrided 2 GetAllLibraries methods.

    It seems to be working, since it's displaying only the libraries we want, but after adding an image, if the sfref of the image (in html code) is something like [OurNewLibraryProvider]{image guid} or the url is ~/OurNewLibraryProvider/... the image is not found.

    The config for our new provider is exactly the same as for Libraries, only the name changes.

    I've tried to change the urlRewriteFormat in the providers config to use the same name as the original libraries provider:
    instead of
    but it was causing huge delays/timeout after each rebuild, I dont really understand why.

    I feel like  my post was missing some details, so let me add a few things:
    -We changed a few dialogs, like for the images, to use our new provider.
    -Some images were added and it worked first.
    -The defaultGenericProvider for libraries is still the original one.

    Can you enlighten me on this ?

    Thank you,

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    19 Oct 2016
    01 Nov 2010
    Link to this post
    Hello Olivier,

    Most probably you are not resolving the dynamic link, please check this post.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered