1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Activating Workflow?

Activating Workflow?

9 posts, 0 answered
  1. Mike
    Mike avatar
    221 posts
    Registered:
    19 Aug 2008
    01 Dec 2008
    Link to this post
    Is there some trick to activating workflow within SiteFinity? We just purchased the standard version of the CMS and i am working with it in my Dev environment, setting everything up. Main reason why we purchased the standard version early was so that i could work with the workflow permissions of the CMS...

    I have created a specific role that i am testing these permissions with. I have set this role to be able to do everything except for create, publish and approove on a specific page of the the site.

    I then log in as that user and still see a publish button and am still able to publish the page changes as this user.

    Am i missing something here? If so could someone point me to the documentation (or just let me know) that tells me the steps to enable workflow for EVERYTHING within the CMS... Pages, Modules, etc...

    Thanks,

    Duncan


  2. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    01 Dec 2008
    Link to this post
    one thing to check is in your web.config under

    <telerik> 
       ...  
     
       <cms allowPageWorkflow="true" ... /> 
     
       ...  
    </telerik> 

    this will ensure that workflow is enabled. I hope this was helpful.
  3. Mike
    Mike avatar
    221 posts
    Registered:
    19 Aug 2008
    01 Dec 2008
    Link to this post
    I get the following error when i add this attribute to this node of the web.config.





    Parser Error Message:
    Unrecognized attribute 'allowPageWorkflow'. Note that attribute names are case-sensitive.

    Source Error:

    Line 324:			</providers>
    Line 325: </security>
    Line 326: <cms defaultProvider="Sitefinity" pageExtension=".aspx"
                            disabled="false" pageEditorUIMode="Overlay" allowPageWorkflow="true">
  4. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    01 Dec 2008
    Link to this post
    my apologies I believe I gave you the incorrect node. it should be node beneath the cms node:

    <providers> 
            <clear /> 
            <add connectionStringName="DefaultConnection" allowPageHistory="true" allowPageWorkflow="true" name="Sitefinity" type="Telerik.Cms.Data.DefaultProvider, Telerik.Cms.Data" /> 
    </providers> 
  5. Mike
    Mike avatar
    221 posts
    Registered:
    19 Aug 2008
    01 Dec 2008
    Link to this post
    I found this post:

    http://www.sitefinity.com/support/forums/support-forum-thread/b1043S-bedbkc.aspx

            <cms defaultProvider="Sitefinity" pageExtension=".aspx" disabled="false" 
       pageEditorUIMode="Overlay"
       <providers> 
        <clear /> 
        <add connectionStringName="DefaultConnection" allowPageHistory="true" 
         allowPageWorkflow="true" name="Sitefinity" type="Telerik.Cms.Data.DefaultProvider, Telerik.Cms.Data" /> 

  6. Mike
    Mike avatar
    221 posts
    Registered:
    19 Aug 2008
    01 Dec 2008
    Link to this post
    :) Seems we figured this out at the same time...

    Testing now, will let you know if it solves this... Thanks

    Duncan
  7. Mike
    Mike avatar
    221 posts
    Registered:
    19 Aug 2008
    01 Dec 2008
    Link to this post
    Ok that seems to work now... Is there anything i should know about workflow for modules in terms of activating it? Or will this cover everything?

    Duncan
  8. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    01 Dec 2008
    Link to this post
    the pageworkflow enables wf only on pages themselves. for more information about enabling workflow on modules, take a look at this knowledgebase article:

    http://www.sitefinity.com/support/knowledge-base/kb-article/b1154K-badt-b1154T-ceb.aspx

    also they are enabled in web.config as well, under the module section, for example:

    <add name="Generic_Content"   
       ... allowWorkflow="true" ...  
       type="Telerik.Cms.Engine.Data.Providers.DefaultProvider, Telerik.Cms.Engine.Data" /> 

    hope this was helpful!
  9. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    02 Dec 2008
    Link to this post
    Hi SelArom,

    Thank you for your very helpful replies! We updated your Telerik account!

    All the best,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Register for webinar
9 posts, 0 answered