1-888-365-2779
+1-888-365-2779
Try Now
More in this section

ASP.NET 3.5

2 posts, 0 answered
  1. Clive Hoggar
    Clive Hoggar avatar
    4 posts
    Registered:
    11 Nov 2008
    13 Jan 2009
    Link to this post
    Hi

    I am almost certain the answer to this questions is 'no problem' but I need to be sure...

    The server on which SiteFinity will be deployed will have asp.net 3.5 installed.
    The SiteFinity system requirments documentation says "asp.net 2.0" required, but are there any issues with asp.net 3.5 version?

    Thanks

    Clive
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    13 Jan 2009
    Link to this post
    Hi Clive Hoggar,

    Yes, the answer is "no problem" indeed :). The .NET framework 3.5 is fully backward compatible with .NET2.0, you only need to update your web.config to use the .NET3.5 framework. This can be done automatically by Visual Studio, once you open the project in it, it will ask you whether you want to convert the project to use newer framework. If you do not convert the project, you will not be able to use the new framework features, but it will still work.

    As additional information, we will release a .Net3.5 build with our next version.

    Sincerely yours,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
2 posts, 0 answered