+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / custom meta in blogs module

custom meta in blogs module

5 posts, 0 answered
  1. Ravikant Gaud
    Ravikant Gaud avatar
    8 posts
    Registered:
    21 Apr 2010
    31 Jan 2011
    Link to this post
    Hi,

    I want to customize Blog module of sitefinity 3.6, I want a "Image Thumbnail" & "File Attachment" field in blog module.
    for that I have created meta filed in web.config with the name "Thumbnails" and "Attachment" respectively and same have used in custom template in admin module it saving the image & file properly but while preview in the browser the image is not coming & for attachment is displaying the library id (see attach image file).
    For preview mode have written blow codes:
    <p class="sf_thumbnail">
       <asp:Image ID="Thumbnails" runat="server" name="Thumbnails" />
    </p>
          
    <p class="file_attached">       
       <asp:HyperLink ID="Attachment" runat="server"  name="Attachment" ></asp:HyperLink>
    </p>

    what I have to do.

    regards,
    Ravikant
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    31 Jan 2011
    Link to this post
    Hello Ravikant,

    Please use FireBug or IE Web tools to inspect the url. You do not see the image, because the url is not properly resolved.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Ravikant Gaud
    Ravikant Gaud avatar
    8 posts
    Registered:
    21 Apr 2010
    31 Jan 2011
    Link to this post
    Hi Ivan,
    Thanks for reply.

    I'm getting below html code:
    <p class="sf_thumbnail">
       <img id="ctl00_Content_BlogPosts1_ctl00_ctl00_Thumbnails" name="Thumbnails" src="" style="border-width:0px;" />
    </p>
          
    <p class="file_attached">       
       <a id="ctl00_Content_BlogPosts1_ctl00_ctl00_Attachment" name="Attachment">[Libraries]5ec0007a-524b-4d32-8894-17ce4ca77732</a>
    </p>

    In this I'm not able to set SRC path for image & HREF link to Attach file, how to do that??

    regards,
    ravikant
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    31 Jan 2011
    Link to this post
    Hi Ravikant,

    You should resolve the dynamic url.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Ravikant Gaud
    Ravikant Gaud avatar
    8 posts
    Registered:
    21 Apr 2010
    31 Jan 2011
    Link to this post
    Hi Ivan,
    I gone through "http://www.sitefinity.com/devnet/forums/sitefinity-3-x/developing-with-sitefinity/adding-thumbnails-to-blog.aspx" this post still having same problem.
    Have create a .cs file in App_code & written the code a mentioned in above post, but not got solution.

    regards,
    ravikant
Register for webinar
5 posts, 0 answered