+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Disable Overlay

Disable Overlay

4 posts, 0 answered
  1. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    15 Mar 2010
    Link to this post
    I can hide the overlay mode with Css, and I see in the webconfig on where to default to Classic Edit mode.

    However, how can I update all existing users to be in Classic mode?  Which DB table is that data stored in?

    Thanks,
    Steve
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    15 Mar 2010
    Link to this post
    Hello Steve,

    1. Disable the Overlay mode from the web.config.
    2. Then you can add the following logic in Sitefinity/Login.aspx.cs Login1_LoggedIn event, so that once an user has been logged in the Page Edit mode will be changed

    EditPageUIMode mode = Telerik.Cms.Configuration.ConfigHelper.Handler.PageEditorUIMode;
    PersonalizationManager pManager = new PersonalizationManager();
    pManager.SaveGlobalValue(GlobalSettingConstants.PageEditorSettingMode, mode);


    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Paritosh Arya
    Paritosh Arya avatar
    10 posts
    Registered:
    18 Dec 2009
    19 Aug 2010
    Link to this post
    I don't know what I am doing wrong but none of the things I tried worked. The "Overlay" option was still the default option. What I want is to set the Classic mode as default for every user. I tried all of these -

    1) Add following code to Login1_LoggedIn eventhandler-
    //Change the default edit mode to Classic
    EditPageUIMode mode = Telerik.Cms.Configuration.ConfigHelper.Handler.PageEditorUIMode;
    PersonalizationManager pManager = new PersonalizationManager();
    pManager.SaveGlobalValue(GlobalSettingConstants.PageEditorSettingMode, mode);

    2) Change the web.config -
    <cms defaultProvider="Sitefinity" pageExtension=".aspx" disabled="false" pageEditorUIMode="Overlay">

    3) Then tried with this option -
    <cms defaultProvider="Sitefinity" pageExtension=".aspx" disabled="false" pageEditorUIMode="Classic">

    Any help would be appreciated. I am using the latest Standard Edition.
  4. Paritosh Arya
    Paritosh Arya avatar
    10 posts
    Registered:
    18 Dec 2009
    19 Aug 2010
    Link to this post
    Don't know what was happening but once I restarted the IIS, everything started working!
Register for webinar
4 posts, 0 answered