+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / IIS - Set up to point to Default.aspx

IIS - Set up to point to Default.aspx

10 posts, 0 answered
  1. Vijaianand
    Vijaianand avatar
    94 posts
    Registered:
    09 Jul 2012
    02 Nov 2010
    Link to this post
    We trying to point the IIS to default.aspx and it doesn't go to the website since its looking for the physical file. I searched the forum to find solution on how to setup the IIS to default page and even tried the web.congig setup to add an handler. Nothing works.

    Help would be appreciated.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    02 Nov 2010
    Link to this post
    Hi VIJAIANAND,

    Why do not you set the default website page from the backend UI, Pages section? There is a link at the bottom left corner that you can use to set your website home page.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Vijaianand
    Vijaianand avatar
    94 posts
    Registered:
    09 Jul 2012
    03 Nov 2010
    Link to this post
    Ivan,

    I tried that but didn't work. When I type the website domain name, it still says file not found but it works if I type with default.aspx.

    Vijai
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    03 Nov 2010
    Link to this post
    Hello VIJAIANAND,

    Try renaming your cms home page to something different than "Default.aspx" and see whether you will get 404 exception after that.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Vijaianand
    Vijaianand avatar
    94 posts
    Registered:
    09 Jul 2012
    03 Nov 2010
    Link to this post
    Ivan,
    The file is actually named home.aspx not default.aspx but looks like sitefinity as functionality inbuilt to direct to the selected home page if you type website/default.aspx. The problem is it doesn't work if you just type the website address. Thats what we are trying to solve. How to transfer the domain/site name to the default page whether its default.aspx or any other page.

    Vijai
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    03 Nov 2010
    Link to this post
    Hello VIJAIANAND,

    Try setting DefaultDocument property of <cms> node to your cms home page

    <cms defaultProvider="Sitefinity" pageExtension=".aspx" DefaultDocument="SetDefaultPage.aspx"
    disabled="false" pageEditorUIMode="Overlay">


    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Vijaianand
    Vijaianand avatar
    94 posts
    Registered:
    09 Jul 2012
    03 Nov 2010
    Link to this post
    I get an error saying,

    Unrecognized attribute 'DefaultDocument'. Note that attribute names are case-sensitive.

    Source Error:

    Line 360:			</providers>
    Line 361:		</security>
    Line 362: <cms defaultProvider="Sitefinity" pageExtension=".aspx" DefaultDocument="Default.aspx" disabled="false" pageEditorUIMode="Overlay">Line 363:			<providers>
    
  8. Vijaianand
    Vijaianand avatar
    94 posts
    Registered:
    09 Jul 2012
    03 Nov 2010
    Link to this post
    fixed the error but didn't work.
  9. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    03 Nov 2010
    Link to this post
    Hi VIJAIANAND,

    The last option that I could come up is setting redirectToHomePage="false". If this does not resolve the issue the the problem is somewhere in your IIS  and how the request has been processed.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Vijaianand
    Vijaianand avatar
    94 posts
    Registered:
    09 Jul 2012
    03 Nov 2010
    Link to this post
    Where this flag needs to be added and how it works?
Register for webinar
10 posts, 0 answered