1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Inserting Document/Library Issue

Inserting Document/Library Issue

4 posts, 0 answered
  1. John
    John avatar
    4 posts
    Registered:
    12 Oct 2008
    29 Jan 2009
    Link to this post
    Hi Team,

    I'm having a issue trying to insert a document link on a page. I'm using Sitefinity 3.5 SP 1.

    I'm trying to insert an existing document from a Document Library that contains around 80 items. When I choose the library from the Insert Document window only 50 items are listed and there is no pagination to browse the other items in the library.
    I've tried changing the 'Max number of files' in the library settings to 100 but I'm still only seeing 50 files in the insert document list.

    Thanks for your help

    John 
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    30 Jan 2009
    Link to this post
    Hi John,

    I assume that you are using RadEditor to insert a document link. Please try the following:

    1.Open ~\Sitefinity\UserControls\Dialogs\ItemDialog.aspx
    2.Edit ItemSelector  control as below:

    <lib:ItemSelector runat="server" ShowMode="Documents" AllowPageSelection="false" ItemsPerPage="100"/> 

    If the above does not fix the problem you could enable AllowPageSelection="true" and set ItemsPerPage property (let say 20, so you will have 5 pages), but this will list Pages, Documents and Files in the RadTabStrip.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. John
    John avatar
    4 posts
    Registered:
    12 Oct 2008
    02 Feb 2009
    Link to this post
    Hi Ivan,
    Thanks for the quick reply, and yes I am using the RadEditor to upload a document.
    Your first solution worked great, but I think that the second solution more be a more appropriate fix for our issue.
    Unfortunatly after I made the changes you described above I was unable to get the pagination working correctly.  The Itemselecter displayed the correct number of Items but did not display any paging controls. 
    I tried changing the ItemsPerPage values and tested using different browsers(ie7, ff3 & google chrome).

    Are you able to shed any light as to why the paging controls aren't displaying?

    Cheers
    John
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    03 Feb 2009
    Link to this post
    Hi John,

    Changing the ShowMode to "All" will set the paging, but It is not a good solution.  you will have "Pages" in the TabStrip.

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Register for webinar
4 posts, 0 answered