1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Is it just me or are the instruction not for ver3.6?

Is it just me or are the instruction not for ver3.6?

3 posts, 0 answered
  1. Mike
    Mike avatar
    221 posts
    Registered:
    19 Aug 2008
    10 Mar 2009
    Link to this post
    Ok i am in the process of applying caching on our site, i want to ensure that AspNet caching is used so that i can use Substitution on some of my dynamic controls.

    Question 1. In 3.6 do i still have to use AspNet caching to use substitution on my controls?

    So i am following this KB article about caching and setting the type in the web.config (KB Article). It specifically says (as does all forum posts on this subject) "To set this you should add a caching attribute to the <cms> tag in the web.config."... Ok simple enough... So i did what it said to:

    ... 
    <cms defaultProvider="Sitefinity" pageExtension=".aspx" disabled="false" 
      pageEditorUIMode="Overlay" caching="AspNet"
      <providers> 
        <clear /> 
        <add connectionStringName="DefaultConnection" allowPageHistory="true" 
          allowPageWorkflow="true" cachingProviderName="ASPNET" name="Sitefinity" 
          type="Telerik.Cms.Data.DefaultProvider, Telerik.Cms.Data" /> 
      </providers> 
    ... 

    And promptly recieve and error:

    Parser Error Message: Unrecognized attribute 'caching'. Note that attribute names are case-sensitive.

    Source Error:

    Line 371:    </security>
    Line 372: <cms defaultProvider="Sitefinity" pageExtension=".aspx" disabled="false"
    Line 373: pageEditorUIMode="Overlay" caching="AspNet">
    Line 374: <providers>
    Line 375: <clear />

    Question 2. Where in the SF 3.6 web.config do we set the cache type?? I want to ensure it is AspNet or InMemory (i would like to try both options)

    Thanks,

    Duncan
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    10 Mar 2009
    Link to this post
    Hello Duncan,

    You should set the caching provider under the section below.

    <framework> 
          <caching defaultProvider="memoryCache"


    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Mike
    Mike avatar
    221 posts
    Registered:
    19 Aug 2008
    10 Mar 2009
    Link to this post
    lol... I just read this in the other post you gave me http://www.sitefinity.com/support/forums/support-forum-thread/b1043S-bmtmda.aspx as you sent this...

    Thanks again!

    Duncan
Register for webinar
3 posts, 0 answered